Uploaded image for project: 'jBPM'
  1. jBPM
  2. JBPM-5122

Firebird SQL support for Datasource

    Details

    • Type: Feature Request
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate Issue
    • Affects Version/s: jBPM 6.3.0.Final
    • Fix Version/s: None
    • Component/s: Dashboard Builder
    • Labels:
      None
    • Environment:

      Wildfly 8.2 Win 64 JDK 1.8 Dashbuilder 6.3

    • Docs QE Status:
      NEW
    • QE Status:
      NEW

      Description

      I have been trying to use Firebird as a datasource with Dash builder. After several attempts and reporting error to Firebird JDBC support the following was recommended by someone on Firebird JAva support list.

      On 20-5-2016 09:20, Mark Rotteveel mark@... [Firebird-Java]
      wrote:
      > Dashbuilder doesn't seem to support Firebird out of the box. See
      > https://github.com/droolsjbpm/dashboard-builder/blob/master/modules/dashboard-commons/src/main/java/org/jboss/dashboard/database/hibernate/HibernateInitializer.java
      >
      > I suggest you file a ticket with them to ask them to add Firebird support.

      Looking closer at it, it might be possible to override the configuration
      of this class by specifying an explicit value for this supportedDialects
      field.

      Looking at
      https://github.com/droolsjbpm/dashboard-builder/blob/master/modules/dashboard-commons/src/main/java/org/jboss/dashboard/annotation/config/ConfigReader.java

      you might be able to create a config file
      META-INF/org.jboss.dashboard.database.hibernate.HibernateInitializer.config

      with value:

      supportedDialects=firebird 1.55li=org.hibernate.dialect.FirebirdDialect

      or maybe include PostgreSQL as well:
      supportedDialects=firebird
      1.55li=org.hibernate.dialect.FirebirdDialect,postgres=org.hibernate.dialect.PostgreSQLDialect

      I am however not sure how this configuration works exactly, so I might
      be wrong; I haven't tried it.

      The code also suggests there is some global config where you would use
      org.jboss.dashboard.database.hibernate.HibernateInitializer.supportedDialects=...
      instead.

      Mark

      Mark Rotteveel

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                davidredhat David Gutierrez
                Reporter:
                loufeliz Lou Feliz
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: