Uploaded image for project: 'JBoss Enterprise Application Platform 4 and 5'
  1. JBoss Enterprise Application Platform 4 and 5
  2. JBPAPP-5135

Autoinstall XML for EWP always installs CXF, even when not asked to

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: EAP_EWP 5.1.0_CR3
    • Fix Version/s: EAP_EWP 5.1.0
    • Component/s: Build
    • Labels:
      None

      Description

      This affects CR3.5, not CR3 as stated in "Affects Version".

      The autoinstall feature for the EWP installer always installs CXF, even though the XML is configured to not install CXF as the WS Stack. When installing manually, this doesn't seems to be the case (ie: I can install EWP without CXF).

      From the logs of the autoinstall, I can see this entry: "Pack [Name: jbossws-cxf and Index: 10] must be installed because it is required!"

      See attached the XML file used (which looks similar to the EAP for this option) and the full log.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                juraci.costa Juraci Paixão Kröhling
                Reporter:
                juraci.costa Juraci Paixão Kröhling
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: