Uploaded image for project: 'JBoss Enterprise Application Platform 4 and 5'
  1. JBoss Enterprise Application Platform 4 and 5
  2. JBPAPP-3924

JBossWS (CXF) - Unable to run wsconsume ant task after installing CXF

    Details

      Description

      After installing the CXF technical preview to a clean JBoss EAP 5 installation I am no longer able to run the wsconsume ant task.

      My classpath for the wsconsume task is now: -

      <path id="project.classpath">
      <fileset dir="${jboss.home}">
      <include name="client/jbossws-spi.jar" />
      <include name="server/default/deployers/jbossws.deployer/jbossws-native-core.jar" />
      <include name="client/jaxws-tools.jar" /> <!-- Copy -->
      <include name="client/streambuffer.jar" /> <!-- Copy -->
      <include name="client/wstx.jar" />
      <include name="client/stax-ex.jar" /> <!-- Copy -->
      </fileset>
      </path>

      The jar jbossws-native-core.jar needed to be added from under deployers, previously all required jars were under client.

      The three jars with <!-- Copy --> after them were missing from the installation and had to be copied back from a clean EAP installation.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  fnasser Fernando Nasser
                  Reporter:
                  dlofthouse Darran Lofthouse
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: