JBoss Enterprise Application Platform 4 and 5
  1. JBoss Enterprise Application Platform 4 and 5
  2. JBPAPP-10157

Type of JMS Connection Factory ALWAYS "JMS Factory" on JBoss EAP 5.1?

    Details

    • Type: Bug Bug
    • Status: Open Open (View Workflow)
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: EAP_EWP 5.1.0
    • Fix Version/s: TBD EAP 5
    • Component/s: HornetQ
    • Security Level: Public (Everyone can see)
    • Environment:
      CentOS 5.5, JBoss EAP 5.1.
    • Affects:
      Release Notes
    • Estimated Difficulty:
      Medium
    • Steps to Reproduce:
      Hide

      Install JBoss EAP 5.1, selecting HornetQ as messaging system.
      Launch JBoss process.
      Access Admin Console in browser.
      Create JMS Connection Factory, selecting type of factory as "JMS XA Factory".
      After successfull creation, select recently created factory, and select Configuration tab.
      You will see type of factory as "JMS Factory" and not as "JMS XA Factory", or whatever you have selected on creation wizard.

      Show
      Install JBoss EAP 5.1, selecting HornetQ as messaging system. Launch JBoss process. Access Admin Console in browser. Create JMS Connection Factory, selecting type of factory as "JMS XA Factory". After successfull creation, select recently created factory, and select Configuration tab. You will see type of factory as "JMS Factory" and not as "JMS XA Factory", or whatever you have selected on creation wizard.
    • Release Notes Text:
      Hide
      Within the JBoss EAP Administration Console, <literal>JMS Connection Factories</literal> can be created with type <literal>JMS XA Factory</literal> (or other). However checking the properties on the <literal>Configuration</literal> tab, it always displays type <literal>JMS Factory</literal>. No workaround is available for this issue.

      The root cause of this under investigation and it is expected to be resolved in a future release.
      Show
      Within the JBoss EAP Administration Console, <literal>JMS Connection Factories</literal> can be created with type <literal>JMS XA Factory</literal> (or other). However checking the properties on the <literal>Configuration</literal> tab, it always displays type <literal>JMS Factory</literal>. No workaround is available for this issue. The root cause of this under investigation and it is expected to be resolved in a future release.
    • Release Notes Docs Status:
      Documented as Known Issue
    • Docs QE Status:
      NEW
    • Similar Issues:
      Show 9 results 

      Description

      From Admin Console we can successfully create JMS Connection Factories, and select type of factory as "JMS XA Factory" (or other); but after creation, when checking properties on Configuration tab, it always returns to "JMS Factory". We need "JMS XA Factory".

        Activity

        There are no comments yet on this issue.

          People

          • Assignee:
            Francisco Borges
            Reporter:
            Daniel BR
            Writer:
            Russell Dickenson
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated: