Details

    • Type: Task
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: JBossOSGi 1.0.0
    • Component/s: None
    • Labels:
      None

      Description

      For JBOSGI-469 the performance tests got re-enabled for JBOSGi and Felix. Equinox still needs to be done.

      On the current codebase the following error appears when running with Equinox:
      .../jbosgi/testsuite/performance $ mvn install -Dtest=Service100TestCase -Dbench=true -Dframework=equinox

      test100(org.jboss.osgi.test.performance.service.arq.Service100TestCase) Time elapsed: 0.041 sec <<< ERROR!
      java.lang.ClassNotFoundException: org.jboss.osgi.test.performance.service.arq.Service100TestCase
      at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:494)
      at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:410)
      at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:398)
      at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:105)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:247)

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  thomas.diesler Thomas Diesler
                  Reporter:
                  bosschaert David Bosschaert
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  0 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: