Uploaded image for project: 'JBoss OSGi'
  1. JBoss OSGi
  2. JBOSGI-473

Unsupported execution environment [OSGi/Minimum-1.2, CDC-1.1/Foundation-1.1, J2SE-1.4] we have [J2SE-1.5, , JavaSE-1.6]

    Details

    • Workaround:
      Workaround Exists
    • Workaround Description:
      Hide

      Change the org.osgi.framework.executionenvironment property in configuration/standalone.xml

      Show
      Change the org.osgi.framework.executionenvironment property in configuration/standalone.xml

      Description

      While deploying a bundle with "Bundle-RequiredExecutionEnvironment: OSGi/Minimum-1.2, CDC-1.1/Foundation-1.1, J2SE-1.4" (Equinox DS) onto JBAS7 CR1 the following exception is thrown:

      "Unsupported execution environment [OSGi/Minimum-1.2, CDC-1.1/Foundation-1.1, J2SE-1.4] we have [J2SE-1.5, , JavaSE-1.6]"

      I think jbosgi should register all EEs down to J2SE-1.4 and on, and thus the bundle should not fail.

      I described it at http://blog.japila.pl/2011/07/help-needed-with-unsupported-execution-environment-deploying-equinox-declarative-services-onto-jboss-as-7-cr1/

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                thomas.diesler Thomas Diesler
                Reporter:
                jlaskowski Jacek Laskowski
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: