Tools (JBoss Tools)
  1. Tools (JBoss Tools)
  2. JBIDE-9381

JBoss runtime detector does not detect SOA 5.2 version correctly

    Details

    • Similar Issues:
      Show 10 results 

      Description

      See attached screenshot.
      This should be fixed before SOA 5.2.GA is out.

      1. jbide-9381-branch.patch
        3 kB
        Snjezana Peco
      2. jbide-9381-trunk.patch
        4 kB
        Snjezana Peco
      1. Screenshot.png
        28 kB

        Activity

        Hide
        Max Rydahl Andersen
        added a comment -

        snjezana - where is that 5.1 version coming from ?

        Show
        Max Rydahl Andersen
        added a comment - snjezana - where is that 5.1 version coming from ?
        Hide
        Rick Wagner
        added a comment -

        Part of 8919?

        Show
        Rick Wagner
        added a comment - Part of 8919?
        Hide
        Snjezana Peco
        added a comment -

        I have fixed this issue using the Implementation-Version property from run.jar.
        The fix changes the org.jboss.ide.eclipse.as.core plugin.
        I have attached patches for the trunk and jbosstools-3.2.x branch.

        Rob, could you please review these patches?

        Show
        Snjezana Peco
        added a comment - I have fixed this issue using the Implementation-Version property from run.jar. The fix changes the org.jboss.ide.eclipse.as.core plugin. I have attached patches for the trunk and jbosstools-3.2.x branch. Rob, could you please review these patches?
        Hide
        Rob Stryker
        added a comment -

        committed hte patches.

        Show
        Rob Stryker
        added a comment - committed hte patches.
        Hide
        Martin Malina
        added a comment -

        Verified in jbosstools-3.3.0.M3-M3-H14 with soa-p-5.2.0.ER3.zip. The version is now detected correctly as 5.2.
        I will leave the closing of this JIRA for 3.2.2.M1.

        Show
        Martin Malina
        added a comment - Verified in jbosstools-3.3.0.M3-M3-H14 with soa-p-5.2.0.ER3.zip. The version is now detected correctly as 5.2. I will leave the closing of this JIRA for 3.2.2.M1.
        Hide
        Pavol Srna
        added a comment -

        Verified alson on jbdevstudio-product-linux-gtk-4.1.1.v201109080253R-H679-M1. Closing.

        Show
        Pavol Srna
        added a comment - Verified alson on jbdevstudio-product-linux-gtk-4.1.1.v201109080253R-H679-M1. Closing.

          People

          • Assignee:
            Rob Stryker
            Reporter:
            Pavol Srna
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: