Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-8366

JBoss Tools and Java Execution Environment

    XMLWordPrintable

    Details

      Description

      Some JBT plugins have the J2SE-1.5 execution environment set although they use classes/methods that only exist in JDK 6.

      The following plugins:

      org.eclipse.bpel.model
      org.eclipse.bpel.ui
      o.j.t.cdi.ui
      o.j.t.jst.jsp

      contain compile errors if there is JDK/JRE 1.5 in the workspace. Since the classes/methods that are being used aren't a part of the language, but a part of JRE, Eclipse can't find those errors because there is only JDK/JRE 1.6 in the workspace.

      The solution is to change the execution environment to JavaSE-1.6

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                snjeza Snjezana Peco
                Reporter:
                snjeza Snjezana Peco
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: