Tools (JBoss Tools)
  1. Tools (JBoss Tools)
  2. JBIDE-6371

org.osgi.framework.BundleException: The bundle "org.eclipse.equinox.ds_1.2.0.v20100507 [2]" could not be resolved. Reason: Missing Constraint: Import-Package: org.eclipse.equinox.internal.util.event; version="1.0.0"

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved (View Workflow)
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: 3.2.0.M1
    • Fix Version/s: 3.2.0.M1
    • Component/s: build
    • Labels:
      None
    • Similar Issues:
      Show 10 results 

      Description

      Starting up Eclipse to do a PDE build as part of the uberbuilder with Eclipse 3.6 & latest basebuilder (first attempt), we get this:

      !SESSION 2010-05-26 17:05:20.741 -----------------------------------------------
      eclipse.buildId=200905221710
      java.version=1.6.0_18
      java.vendor=Sun Microsystems Inc.
      BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
      Framework arguments: -application org.eclipse.ant.core.antRunner -f /qa/hudson_ws/workspace/jbosstools-continuous-3.2.helios/org.jboss.ide.eclipse.releng/builders/product/productBuild.xml run.builders
      Command-line arguments: -application org.eclipse.ant.core.antRunner -data /qa/hudson_ws/workspace/jbosstools-continuous-3.2.helios/jbds-build/workspace -f /qa/hudson_ws/workspace/jbosstools-continuous-3.2.helios/org.jboss.ide.eclipse.releng/builders/product/productBuild.xml run.builders

      !ENTRY org.eclipse.equinox.ds 4 0 2010-05-26 17:05:26.014
      !MESSAGE
      !STACK 0
      org.osgi.framework.BundleException: The bundle "org.eclipse.equinox.ds_1.2.0.v20100507 [2]" could not be resolved. Reason: Missing Constraint: Import-Package: org.eclipse.equinox.internal.util.event; version="1.0.0"
      at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1317)
      at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1301)
      at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:319)
      at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:374)
      at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1067)
      at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:561)
      at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:546)
      at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:459)
      at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
      at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:440)
      at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:227)
      at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:337)

      !ENTRY org.eclipse.update.configurator 4 0 2010-05-26 17:05:26.605
      !MESSAGE Could not install bundle plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar Bundle "org.eclipse.equinox.launcher" version "1.1.0.v20100507" has already been installed from: update@plugins/org.eclipse.equinox.launcher.jar

      !ENTRY org.eclipse.osgi 4 0 2010-05-26 17:05:26.648
      !MESSAGE An unexpected runtime error has occurred.
      !STACK 0
      javax.xml.parsers.FactoryConfigurationError: Provider org.apache.xerces.jaxp.SAXParserFactoryImpl not found
      at javax.xml.parsers.SAXParserFactory.newInstance(SAXParserFactory.java:134)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAdaptorHook$ParsingService.createService(EclipseAdaptorHook.java:147)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAdaptorHook$ParsingService.getService(EclipseAdaptorHook.java:139)

      http://hudson.qa.jboss.com/hudson/view/DevStudio/job/jbosstools-continuous-3.2.helios/ws/jbds-build/org.eclipse.releng.basebuilder/configuration/1274907921117.log

      No idea what's causing this, much less how to fix.

        Issue Links

          Activity

          Snjezana Peco
          added a comment -

          Adding -Dosgi.bundles=org.eclipse.equinox.simpleconfigurator@1\:start,org.eclipse.equinox.util@2\:start doesn't work for the two reasons:

          • org.eclipse.releng.basebuilder doesn't contain P2 metadata and org.eclipse.equinox.simpleconfigurator can't be used
          • -Dosgi.bundles=... has to be added as a VM argument using <jvmarg value="-Dosgi.bundles=..." /> instead of <arg line="-Dosgi.bundles=..." />

          In order the update configurator to work, it is necessary to add the following:
          <jvmarg value="-Dosgi.bundles=org.eclipse.equinox.common@2\:start,org.eclipse.equinox.ds@2\:start,org.eclipse.update.configurator@3\:start,org.eclipse.core.runtime@start,org.eclipse.equinox.util@2\:start,org.eclipse.osgi.services@2\:start" />

          Show
          Snjezana Peco
          added a comment - Adding -Dosgi.bundles=org.eclipse.equinox.simpleconfigurator@1\:start,org.eclipse.equinox.util@2\:start doesn't work for the two reasons: org.eclipse.releng.basebuilder doesn't contain P2 metadata and org.eclipse.equinox.simpleconfigurator can't be used -Dosgi.bundles=... has to be added as a VM argument using <jvmarg value="-Dosgi.bundles=..." /> instead of <arg line="-Dosgi.bundles=..." /> In order the update configurator to work, it is necessary to add the following: <jvmarg value="-Dosgi.bundles=org.eclipse.equinox.common@2\:start,org.eclipse.equinox.ds@2\:start,org.eclipse.update.configurator@3\:start,org.eclipse.core.runtime@start,org.eclipse.equinox.util@2\:start,org.eclipse.osgi.services@2\:start" />
          Snjezana Peco
          added a comment -

          You need to write <jvmarg value="-Dosgi.bundles..." /> instead of <arg value="-Dosgi.bundles..."... />

          Show
          Snjezana Peco
          added a comment - You need to write <jvmarg value="-Dosgi.bundles..." /> instead of <arg value="-Dosgi.bundles..."... />
          Nick Boldt
          added a comment -

          http://hudson.qa.jboss.com/hudson/job/jbosstools-nightly-3.2.helios/51/consoleFull
          http://hudson.qa.jboss.com/hudson/job/jbosstools-nightly-3.2.helios/51/changes

          !SESSION 2010-06-01 14:16:28.260 -----------------------------------------------
          eclipse.buildId=200905221710
          java.version=1.6.0_18
          java.vendor=Sun Microsystems Inc.
          BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
          Framework arguments: -application org.eclipse.ant.core.antRunner -f /mnt/hudson_workspace/workspace/jbosstools-nightly-3.2.helios/org.jboss.ide.eclipse.releng/builders/product/productBuild.xml build.standalone.release -Dosgi.bundles=org.eclipse.equinox.simpleconfigurator@1\:start
          Command-line arguments: -application org.eclipse.ant.core.antRunner -data /mnt/hudson_workspace/workspace/jbosstools-nightly-3.2.helios/jbds-build/workspace -f /mnt/hudson_workspace/workspace/jbosstools-nightly-3.2.helios/org.jboss.ide.eclipse.releng/builders/product/productBuild.xml build.standalone.release -Dosgi.bundles=org.eclipse.equinox.simpleconfigurator@1\:start

          !ENTRY org.eclipse.equinox.ds 4 0 2010-06-01 14:16:29.742
          !MESSAGE
          !STACK 0
          org.osgi.framework.BundleException: The bundle "org.eclipse.equinox.ds_1.2.0.v20100507 [2]" could not be resolved. Reason: Missing Constraint: Import-Package: org.eclipse.equinox.internal.util.event; version="1.0.0"

          (didn't work.)

          So, I tried using BOTH jvmarg and arg and got a new error:

          http://hudson.qa.jboss.com/hudson/job/jbosstools-nightly-3.2.helios/52/consoleFull
          http://hudson.qa.jboss.com/hudson/job/jbosstools-nightly-3.2.helios/52/changes

          !SESSION 2010-06-07 17:49:59.105 -----------------------------------------------
          eclipse.buildId=200905221710
          java.version=1.6.0_18
          java.vendor=Sun Microsystems Inc.
          BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
          Framework arguments: -application org.eclipse.ant.core.antRunner -f /mnt/hudson_workspace/workspace/jbosstools-nightly-3.2.helios/org.jboss.ide.eclipse.releng/builders/product/productBuild.xml build.standalone.release -Dosgi.bundles=org.eclipse.equinox.common@2\:start,org.eclipse.equinox.ds@2\:start,org.eclipse.update.configurator@3\:start,org.eclipse.core.runtime@start,org.eclipse.equinox.util@2\:start,org.eclipse.osgi.services@2\:start
          Command-line arguments: -application org.eclipse.ant.core.antRunner -data /mnt/hudson_workspace/workspace/jbosstools-nightly-3.2.helios/jbds-build/workspace -f /mnt/hudson_workspace/workspace/jbosstools-nightly-3.2.helios/org.jboss.ide.eclipse.releng/builders/product/productBuild.xml build.standalone.release -Dosgi.bundles=org.eclipse.equinox.common@2\:start,org.eclipse.equinox.ds@2\:start,org.eclipse.update.configurator@3\:start,org.eclipse.core.runtime@start,org.eclipse.equinox.util@2\:start,org.eclipse.osgi.services@2\:start

          !ENTRY org.eclipse.osgi 4 0 2010-06-07 17:50:00.573
          !MESSAGE Bundle org.eclipse.equinox.common@2\:start not found.

          !ENTRY org.eclipse.osgi 4 0 2010-06-07 17:50:00.574
          !MESSAGE Bundle org.eclipse.equinox.ds@2\:start not found.

          !ENTRY org.eclipse.osgi 4 0 2010-06-07 17:50:00.574
          !MESSAGE Bundle org.eclipse.update.configurator@3\:start not found.

          !ENTRY org.eclipse.osgi 4 0 2010-06-07 17:50:00.581
          !MESSAGE Bundle org.eclipse.equinox.util@2\:start not found.

          !ENTRY org.eclipse.osgi 4 0 2010-06-07 17:50:00.582
          !MESSAGE Bundle org.eclipse.osgi.services@2\:start not found.

          !ENTRY org.eclipse.core.runtime 4 0 2010-06-07 17:50:00.714
          !MESSAGE
          !STACK 0
          org.osgi.framework.BundleException: The bundle "org.eclipse.core.runtime_3.6.0.v20100505 [1]" could not be resolved. Reason: Missing Constraint: Require-Bundle: org.eclipse.equinox.common; bundle-version="[3.5.0,4.0.0)"

          Show
          Nick Boldt
          added a comment - http://hudson.qa.jboss.com/hudson/job/jbosstools-nightly-3.2.helios/51/consoleFull http://hudson.qa.jboss.com/hudson/job/jbosstools-nightly-3.2.helios/51/changes !SESSION 2010-06-01 14:16:28.260 ----------------------------------------------- eclipse.buildId=200905221710 java.version=1.6.0_18 java.vendor=Sun Microsystems Inc. BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US Framework arguments: -application org.eclipse.ant.core.antRunner -f /mnt/hudson_workspace/workspace/jbosstools-nightly-3.2.helios/org.jboss.ide.eclipse.releng/builders/product/productBuild.xml build.standalone.release -Dosgi.bundles=org.eclipse.equinox.simpleconfigurator@1\:start Command-line arguments: -application org.eclipse.ant.core.antRunner -data /mnt/hudson_workspace/workspace/jbosstools-nightly-3.2.helios/jbds-build/workspace -f /mnt/hudson_workspace/workspace/jbosstools-nightly-3.2.helios/org.jboss.ide.eclipse.releng/builders/product/productBuild.xml build.standalone.release -Dosgi.bundles=org.eclipse.equinox.simpleconfigurator@1\:start !ENTRY org.eclipse.equinox.ds 4 0 2010-06-01 14:16:29.742 !MESSAGE !STACK 0 org.osgi.framework.BundleException: The bundle "org.eclipse.equinox.ds_1.2.0.v20100507 [2] " could not be resolved. Reason: Missing Constraint: Import-Package: org.eclipse.equinox.internal.util.event; version="1.0.0" (didn't work.) So, I tried using BOTH jvmarg and arg and got a new error: http://hudson.qa.jboss.com/hudson/job/jbosstools-nightly-3.2.helios/52/consoleFull http://hudson.qa.jboss.com/hudson/job/jbosstools-nightly-3.2.helios/52/changes !SESSION 2010-06-07 17:49:59.105 ----------------------------------------------- eclipse.buildId=200905221710 java.version=1.6.0_18 java.vendor=Sun Microsystems Inc. BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US Framework arguments: -application org.eclipse.ant.core.antRunner -f /mnt/hudson_workspace/workspace/jbosstools-nightly-3.2.helios/org.jboss.ide.eclipse.releng/builders/product/productBuild.xml build.standalone.release -Dosgi.bundles=org.eclipse.equinox.common@2\:start,org.eclipse.equinox.ds@2\:start,org.eclipse.update.configurator@3\:start,org.eclipse.core.runtime@start,org.eclipse.equinox.util@2\:start,org.eclipse.osgi.services@2\:start Command-line arguments: -application org.eclipse.ant.core.antRunner -data /mnt/hudson_workspace/workspace/jbosstools-nightly-3.2.helios/jbds-build/workspace -f /mnt/hudson_workspace/workspace/jbosstools-nightly-3.2.helios/org.jboss.ide.eclipse.releng/builders/product/productBuild.xml build.standalone.release -Dosgi.bundles=org.eclipse.equinox.common@2\:start,org.eclipse.equinox.ds@2\:start,org.eclipse.update.configurator@3\:start,org.eclipse.core.runtime@start,org.eclipse.equinox.util@2\:start,org.eclipse.osgi.services@2\:start !ENTRY org.eclipse.osgi 4 0 2010-06-07 17:50:00.573 !MESSAGE Bundle org.eclipse.equinox.common@2\:start not found. !ENTRY org.eclipse.osgi 4 0 2010-06-07 17:50:00.574 !MESSAGE Bundle org.eclipse.equinox.ds@2\:start not found. !ENTRY org.eclipse.osgi 4 0 2010-06-07 17:50:00.574 !MESSAGE Bundle org.eclipse.update.configurator@3\:start not found. !ENTRY org.eclipse.osgi 4 0 2010-06-07 17:50:00.581 !MESSAGE Bundle org.eclipse.equinox.util@2\:start not found. !ENTRY org.eclipse.osgi 4 0 2010-06-07 17:50:00.582 !MESSAGE Bundle org.eclipse.osgi.services@2\:start not found. !ENTRY org.eclipse.core.runtime 4 0 2010-06-07 17:50:00.714 !MESSAGE !STACK 0 org.osgi.framework.BundleException: The bundle "org.eclipse.core.runtime_3.6.0.v20100505 [1] " could not be resolved. Reason: Missing Constraint: Require-Bundle: org.eclipse.equinox.common; bundle-version="[3.5.0,4.0.0)"
          Snjezana Peco
          added a comment -

          The problem is "\" in the plugin name. I have fixed it.

          Show
          Snjezana Peco
          added a comment - The problem is "\" in the plugin name. I have fixed it.
          Nick Boldt
          added a comment -

          Fixed. Seems that the file builder-wrap.xml is cached and so even when it's refreshed from SVN it doesn't get into the build. PITA, that.

          Show
          Nick Boldt
          added a comment - Fixed. Seems that the file builder-wrap.xml is cached and so even when it's refreshed from SVN it doesn't get into the build. PITA, that.

            People

            • Assignee:
              Nick Boldt
              Reporter:
              Nick Boldt
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: