Tools (JBoss Tools)
  1. Tools (JBoss Tools)
  2. JBIDE-5463

BPEL Editor gives validation errors after creating correlation variables

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved (View Workflow)
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: LATER
    • Component/s: bpm
    • Labels:
      None
    • Environment:
        JBoss BPEL Editor 1.0.0.v200912111224M-H175-RC1 org.jboss.tools.bpel.feature.feature.group on Mac with JDK 1.6
    • Similar Issues:
      Show 10 results 

      Description

      I created a CorrelationSet with a single correlation variable and four mappings. After doing this and cleaning the project I get four errors:

      Description Resource Path Location Type
      The XPath segment "child::receivePolicyQuote" cannot be resolved. PolicyQuoteProcessArtifacts.wsdl /PolicyQuoteProcessService/bpelContent query BPEL Validation Marker

      Description Resource Path Location Type
      The XPath segment "child::receivePolicyQuote" cannot be resolved. PolicyQuoteProcessArtifacts.wsdl /PolicyQuoteProcessService/bpelContent query BPEL Validation Marker

      Description Resource Path Location Type
      The XPath segment "child::ssn" cannot be resolved. PolicyQuoteProcessArtifacts.wsdl /PolicyQuoteProcessService/bpelContent query BPEL Validation Marker

      Description Resource Path Location Type
      The XPath segment "child::ssn" cannot be resolved. PolicyQuoteProcessArtifacts.wsdl /PolicyQuoteProcessService/bpelContent query BPEL Validation Marker

      I will zip up and attach the project files.

        Activity

        Jeff DeLong
        made changes -
        Field Original Value New Value
        Attachment PolicyQuoteProcessService.zip [ 12330805 ]
        Denny Xu
        made changes -
        Assignee Denny Xu [ dennyxu ]
        Denny Xu
        added a comment -

        Jeff, in the wsdl file, this parts of content like below:

        <vprop:propertyAlias messageType="wsdl5:PolicyQuoteProcessServiceReq" part="in" propertyName="tns:SSN">
        <vprop:query><![CDATA[/receivePolicyQuote/policyQuoteInfo/ssn]]></vprop:query>
        </vprop:propertyAlias>
        <vprop:propertyAlias messageType="wsdl1:DrivingRecordServiceReq" part="in" propertyName="tns:SSN">
        <vprop:query><![CDATA[/ssn]]></vprop:query>
        </vprop:propertyAlias>
        <vprop:propertyAlias messageType="wsdl4:DrivingRecordCallbackServiceReq" part="in" propertyName="tns:SSN">
        <vprop:query><![CDATA[/ssn]]></vprop:query>
        </vprop:propertyAlias>
        <vprop:propertyAlias messageType="wsdl5:PolicyQuoteProcessServiceRes" part="out" propertyName="tns:SSN">
        <vprop:query><![CDATA[/receivePolicyQuote/policyQuoteInfo/ssn]]></vprop:query>
        </vprop:propertyAlias>

        because there is no prefix for /receivePolicyQuote/policyQuoteInfo/ssn, shouldn't it be something like /pol:receivePolicyQuote/pol:policyQuoteInfo/pol:ssn, if it doesn't need prefix, what does it point to?

        Show
        Denny Xu
        added a comment - Jeff, in the wsdl file, this parts of content like below: <vprop:propertyAlias messageType="wsdl5:PolicyQuoteProcessServiceReq" part="in" propertyName="tns:SSN"> <vprop:query><![CDATA [/receivePolicyQuote/policyQuoteInfo/ssn] ]></vprop:query> </vprop:propertyAlias> <vprop:propertyAlias messageType="wsdl1:DrivingRecordServiceReq" part="in" propertyName="tns:SSN"> <vprop:query><![CDATA [/ssn] ]></vprop:query> </vprop:propertyAlias> <vprop:propertyAlias messageType="wsdl4:DrivingRecordCallbackServiceReq" part="in" propertyName="tns:SSN"> <vprop:query><![CDATA [/ssn] ]></vprop:query> </vprop:propertyAlias> <vprop:propertyAlias messageType="wsdl5:PolicyQuoteProcessServiceRes" part="out" propertyName="tns:SSN"> <vprop:query><![CDATA [/receivePolicyQuote/policyQuoteInfo/ssn] ]></vprop:query> </vprop:propertyAlias> because there is no prefix for /receivePolicyQuote/policyQuoteInfo/ssn , shouldn't it be something like /pol:receivePolicyQuote/pol:policyQuoteInfo/pol:ssn , if it doesn't need prefix, what does it point to?
        Max Rydahl Andersen
        made changes -
        Fix Version/s LATER [ 12311660 ]
        Jeff DeLong
        added a comment -

        Denny, You might be correct but this is what the correlation variable editor created. How should it handle prefixes?

        Show
        Jeff DeLong
        added a comment - Denny, You might be correct but this is what the correlation variable editor created. How should it handle prefixes?
        Denny Xu
        added a comment -

        Confirmed with Gary, the expression need namespace, so it is the issue of bpel editor, editor should add namespace when creating the correlation variable.

        Assign the issue to Grid to fix the editor side issue.

        Show
        Denny Xu
        added a comment - Confirmed with Gary, the expression need namespace, so it is the issue of bpel editor, editor should add namespace when creating the correlation variable. Assign the issue to Grid to fix the editor side issue.
        Denny Xu
        made changes -
        Assignee Denny Xu [ dennyxu ] Feng Qian [ grid.qian ]
        Feng Qian
        31/Dec/09 12:33 AM
        View full commit
        JBIDE-5463: BPEL Editor gives validation errors after creating correlation variables git-svn-id: http://svn.jboss.org/repos/jbosstools/trunk@19633 a97e2381-89e5-4abb-bab3-167db6db766c
        Feng Qian <fqian@redhat.com> committed 65b5d64d4131295035d12cde0f558586dc162f3b (2 files)
        Feng Qian
        added a comment -

        fixed

        Show
        Feng Qian
        added a comment - fixed
        Feng Qian
        made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Done [ 1 ]
        Feng Qian
        added a comment -

        patch

        Show
        Feng Qian
        added a comment - patch
        Feng Qian
        made changes -
        Attachment org.eclipse.bpel.ui.patch [ 12331119 ]
        Feng Qian
        added a comment -

        create a bug for this issue in eclipse bpel: https://bugs.eclipse.org/bugs/show_bug.cgi?id=298670

        Show
        Feng Qian
        added a comment - create a bug for this issue in eclipse bpel: https://bugs.eclipse.org/bugs/show_bug.cgi?id=298670
        Vlastimil Eliáš
        made changes -
        Workflow jira [ 12407329 ] GIT Pull Request workflow [ 12508329 ]

          People

          • Assignee:
            Feng Qian
            Reporter:
            Jeff DeLong
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: