Details

      Description

      I installed devstudio 12 nightly [1] today and saw this error in the Error Log view:

      FrameworkEvent ERROR
      
      org.osgi.framework.BundleException: Could not resolve module: org.eclipse.wst.server.preview [777]
        Unresolved requirement: Require-Bundle: org.eclipse.jetty.servlet; bundle-version="[9.4.7,10.0.0)"
          -> Bundle-SymbolicName: org.eclipse.jetty.servlet; bundle-version="9.4.9.v20180320"
             org.eclipse.jetty.servlet [363]
               Unresolved requirement: Import-Package: org.eclipse.jetty.http; version="[9.4.9,9.4.10)"
                 -> Export-Package: org.eclipse.jetty.http; bundle-symbolic-name="org.eclipse.jetty.http"; bundle-version="9.4.9.v20180320"; version="9.4.9"; uses:="org.eclipse.jetty.io,org.eclipse.jetty.util,org.eclipse.jetty.util.component,org.eclipse.jetty.util.log,org.eclipse.jetty.util.resource"
                    org.eclipse.jetty.http [355]
                      Unresolved requirement: Import-Package: org.eclipse.jetty.io; version="[9.4.9,9.4.10)"
                        -> Export-Package: org.eclipse.jetty.io; bundle-symbolic-name="org.eclipse.jetty.io"; bundle-version="9.4.9.v20180320"; version="9.4.9"; uses:="javax.net.ssl,org.eclipse.jetty.util,org.eclipse.jetty.util.annotation,org.eclipse.jetty.util.component,org.eclipse.jetty.util.log,org.eclipse.jetty.util.thread"
                           org.eclipse.jetty.io [357]
                             Unresolved requirement: Import-Package: org.eclipse.jetty.util.annotation; version="[9.4.9,9.4.10)"
                               -> Export-Package: org.eclipse.jetty.util.annotation; bundle-symbolic-name="org.eclipse.jetty.util"; bundle-version="9.4.9.v20180320"; version="9.4.9"
                                  org.eclipse.jetty.util [365]
                                    Unresolved requirement: Require-Capability: osgi.serviceloader; filter:="(osgi.serviceloader=org.eclipse.jetty.util.security.CredentialProvider)"; resolution:="optional"; cardinality:="multiple"
                                    Unresolved requirement: Require-Capability: osgi.extender; filter:="(osgi.extender=osgi.serviceloader.processor)"
                             Unresolved requirement: Import-Package: org.eclipse.jetty.util; version="[9.4.9,9.4.10)"
                               -> Export-Package: org.eclipse.jetty.util; bundle-symbolic-name="org.eclipse.jetty.util"; bundle-version="9.4.9.v20180320"; version="9.4.9"; uses:="javax.servlet,javax.servlet.http,org.eclipse.jetty.util.annotation,org.eclipse.jetty.util.component,org.eclipse.jetty.util.log,org.eclipse.jetty.util.resource,org.eclipse.jetty.util.thread"
                      Unresolved requirement: Import-Package: org.eclipse.jetty.util; version="[9.4.9,9.4.10)"
                        -> Export-Package: org.eclipse.jetty.util; bundle-symbolic-name="org.eclipse.jetty.util"; bundle-version="9.4.9.v20180320"; version="9.4.9"; uses:="javax.servlet,javax.servlet.http,org.eclipse.jetty.util.annotation,org.eclipse.jetty.util.component,org.eclipse.jetty.util.log,org.eclipse.jetty.util.resource,org.eclipse.jetty.util.thread"
        Unresolved requirement: Require-Bundle: org.eclipse.jetty.security; bundle-version="[9.4.7,10.0.0)"
          -> Bundle-SymbolicName: org.eclipse.jetty.security; bundle-version="9.4.9.v20180320"
             org.eclipse.jetty.security [359]
               Unresolved requirement: Import-Package: org.eclipse.jetty.http; version="[9.4.9,9.4.10)"
                 -> Export-Package: org.eclipse.jetty.http; bundle-symbolic-name="org.eclipse.jetty.http"; bundle-version="9.4.9.v20180320"; version="9.4.9"; uses:="org.eclipse.jetty.io,org.eclipse.jetty.util,org.eclipse.jetty.util.component,org.eclipse.jetty.util.log,org.eclipse.jetty.util.resource"
        Unresolved requirement: Require-Bundle: org.eclipse.jetty.xml; bundle-version="[9.4.7,10.0.0)"
          -> Bundle-SymbolicName: org.eclipse.jetty.xml; bundle-version="9.4.9.v20180320"
             org.eclipse.jetty.xml [368]
               Unresolved requirement: Import-Package: org.eclipse.jetty.util; version="[9.4.9,9.4.10)"
                 -> Export-Package: org.eclipse.jetty.util; bundle-symbolic-name="org.eclipse.jetty.util"; bundle-version="9.4.9.v20180320"; version="9.4.9"; uses:="javax.servlet,javax.servlet.http,org.eclipse.jetty.util.annotation,org.eclipse.jetty.util.component,org.eclipse.jetty.util.log,org.eclipse.jetty.util.resource,org.eclipse.jetty.util.thread"
        Unresolved requirement: Require-Bundle: org.eclipse.jetty.io; bundle-version="[9.4.7,10.0.0)"
          -> Bundle-SymbolicName: org.eclipse.jetty.io; bundle-version="9.4.9.v20180320"
        Unresolved requirement: Require-Bundle: org.eclipse.jetty.server; bundle-version="[9.4.7,10.0.0)"
          -> Bundle-SymbolicName: org.eclipse.jetty.server; bundle-version="9.4.9.v20180320"
             org.eclipse.jetty.server [361]
               Unresolved requirement: Import-Package: org.eclipse.jetty.http; version="[9.4.9,9.4.10)"
                 -> Export-Package: org.eclipse.jetty.http; bundle-symbolic-name="org.eclipse.jetty.http"; bundle-version="9.4.9.v20180320"; version="9.4.9"; uses:="org.eclipse.jetty.io,org.eclipse.jetty.util,org.eclipse.jetty.util.component,org.eclipse.jetty.util.log,org.eclipse.jetty.util.resource"
        Unresolved requirement: Require-Bundle: org.eclipse.jetty.http; bundle-version="[9.4.7,10.0.0)"
          -> Bundle-SymbolicName: org.eclipse.jetty.http; bundle-version="9.4.9.v20180320"
        Unresolved requirement: Require-Bundle: org.eclipse.jetty.util; bundle-version="[9.4.7,10.0.0)"
          -> Bundle-SymbolicName: org.eclipse.jetty.util; bundle-version="9.4.9.v20180320"
        Unresolved requirement: Require-Bundle: org.eclipse.jetty.webapp; bundle-version="[9.4.7,10.0.0)"
          -> Bundle-SymbolicName: org.eclipse.jetty.webapp; bundle-version="9.4.9.v20180320"
             org.eclipse.jetty.webapp [367]
               Unresolved requirement: Import-Package: org.eclipse.jetty.http; version="[9.4.9,9.4.10)"
                 -> Export-Package: org.eclipse.jetty.http; bundle-symbolic-name="org.eclipse.jetty.http"; bundle-version="9.4.9.v20180320"; version="9.4.9"; uses:="org.eclipse.jetty.io,org.eclipse.jetty.util,org.eclipse.jetty.util.component,org.eclipse.jetty.util.log,org.eclipse.jetty.util.resource"
      
      	at org.eclipse.osgi.container.Module.start(Module.java:444)
      	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
      	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1661)
      	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
      	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
      	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
      	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
      	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
      

      It's not strictly server tools related, but maybe you can take a look.
      I checked in plain Eclipse Java EE Photon M6 bundle and the error wasn't there.

      [1] devstudio-12.0.0.AM1-v20180502-0411-B2377-installer-standalone.jar

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  nickboldt Nick Boldt
                  Reporter:
                  mmalina Martin Malina
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: