Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-25665

It is not possible to update from 4.5.1. to 4.5.2.Final using Check for Update

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 4.5.2.Final
    • Fix Version/s: 4.5.3.AM1
    • Component/s: build
    • Labels:
      None
    • Steps to Reproduce:
      Hide
      Show
      Download and unzip eclipse-jee-oxygen-1a-linux-gtk-x86_64 Install JBT 4.5.1.Final form jbosstools-4.5.1.Final-updatesite-core.zip (it is not logner available in Eclipse Marketplace) Open Preferences->Available Software Sites Remove/disable update site pointing to jbosstools-4.5.1.Final-updatesite-core.zip Add 4.5.2. update site http://download.jboss.org/jbosstools/oxygen/stable/updates/ Help->Check for Updates
    • Workaround:
      Workaround Exists
    • Workaround Description:
      Hide

      Update to JBossTools 4.5.2.Final using Eclipse Marketplace or using "Install New Software".

      Show
      Update to JBossTools 4.5.2.Final using Eclipse Marketplace or using "Install New Software". Click Help->Install New Software Add JBossTools stable update site ( http://download.jboss.org/jbosstools/oxygen/stable/updates/ ) Select "Abridged JBoss Tools" and "Additional JBoss Tools" or whatever you want Click next and on Remediation Page choose "Update my installation..."

      Description

      It is not possible to update to 4.5.2.Final using "Check for Update". Check for Update is not able to find any remedy for this conflict:

      Cannot complete the install because of a conflicting dependency.
        Software being installed: JBoss JAX-RS Tools 2.0.0.v20180105-1426 (org.jboss.tools.ws.jaxrs.feature.feature.group 2.0.0.v20180105-1426)
        Software currently installed: JBoss WebServices Tools 1.9.101.v20170822-1704 (org.jboss.tools.ws.feature.feature.group 1.9.101.v20170822-1704)
        Only one of the following can be installed at once: 
          JBoss WebServices Tools 2.0.0.v20180105-1426 (org.jboss.tools.ws.ui 2.0.0.v20180105-1426)
          JBoss WebServices Tools 1.9.101.v20170822-1704 (org.jboss.tools.ws.ui 1.9.101.v20170822-1704)
        Cannot satisfy dependency:
          From: JBoss WebServices Tools 1.9.101.v20170822-1704 (org.jboss.tools.ws.feature.feature.group 1.9.101.v20170822-1704)
          To: org.jboss.tools.ws.ui [1.9.101.v20170822-1704]
        Cannot satisfy dependency:
          From: JBoss JAX-RS Tools 2.0.0.v20180105-1426 (org.jboss.tools.ws.jaxrs.feature.feature.group 2.0.0.v20180105-1426)
          To: org.jboss.tools.ws.ui [2.0.0.v20180105-1426]
      

      It is maybe caused by separation of SOAP from jbosstools-webservices (JBIDE-24880).

      This process is routinely tested and the test passed on Friday/Monday, but unfortunately I made a mistake. I installed JBT 4.5.1 from Eclipse Marketplace, then I added staging update site and executed Check for Update which passed without any problems. But I didn't realize that JBT 4.5.1 added stable update site for 4.5.1, which was used together with 4.5.2 update site, so it was able to resolve that conflict. So I apologize for this issue.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  nickboldt Nick Boldt
                  Reporter:
                  lvalach Lukáš Valach
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: