Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-19879

Add o.e.remote and o.e.launchbar to TP

    XMLWordPrintable

    Details

      Description

      Reason: JBIDE-19711 - WTP servertools integration with CDT launchbar
      Project page/sources: ... Requires dependencies on CDT and Launchbar. Launchbar is in http://www.eclipse.org/cdt/ and o.e.remote is in http://www.eclipse.org/ptp/

      Version: - Required launchbar is 1.0.0 found in MASTER at their repository. There is no released version yet with the stable API required. Required o.e.remote version is 2.0.0 in MASTER at their repository. There is no released version yet with the stable API required.

      License and owner: ... Both are eclipse projects licensed under EPL

      Original p2 repo: I am unable to locate the original update sites / p2 repos. PTP does not seem to have an update site URL to the best of my searching (http://download.eclipse.org/tools/ptp/builds/9.0.0/ does not list an update site url, but does have a zip containing an update site). CDT does not list update sites for mars at https://eclipse.org/cdt/downloads.php

      JBoss mirror: - Not sure what's applicable here. http://download.jboss.org/jbosstools/updates/requirements/mars/201505081000-M7/plugins/ does have all plugins needed, but none are the API required, as we require the code from Master.

      *Include Sources: - It's always nice to include sources for devs who build tp locally with the fetch-sources flag

      *Affected projects: - jbosstools-server

      Include in JBDS: - No, for now.

      Type of dependency: distribution

      List of bundles added/removed: - At this time, I expect to require org.eclipse.launchbar.core, org.eclipse.launchbar.ui, org.eclipse.remote.core, org.eclipse.remote.ui.

      Unfortunately I'm unable to test if this is sufficient, at the moment. There may be other plugins that are transient deps somehow that I'm not seeing since I don't have a TP to build against that works.

      If applicable:
      non-p2 repository: ???
      non-p2 ids: ???

      Suggested Patch for TP: - At this point, I have no suggested patch. I do not know how to add a dependency on nightly builds for these two blocks of code. Also, I'm a bit confused why http://download.jboss.org/jbosstools/updates/requirements/mars/201505081000-M7/plugins/ will list a plugin (for example org.eclipse.cdt.core.native_5.8.0.201505050312.jar) but the .target file references a feature group which is not present in the requirements/mars folder, such as <unit id="org.eclipse.cdt.native.feature.group" version="8.7.0.201505050312"/>

      I'm also a bit confused where you're pulling the feature group name / id from, or its version, as the version of the feature group does not seem to match the version of the plugin. Furthermore, the mars repo mentioned above does not seem to include any file matching the string org.eclipse.cdt.native.feature.group

      So I'm not sure how you're converting a required plugin id to a feature group. The devdoc also provides no assistance in this matter.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  nickboldt Nick Boldt
                  Reporter:
                  rob.stryker Rob Stryker
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: