Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-19834

Change Base's Bundle-RequireExecutionEnvironment to require Java8 (not 7)

    Details

    • Type: Task
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 4.3.0.Alpha2
    • Fix Version/s: 4.3.0.Beta1
    • Component/s: common
    • Labels:
      None

      Description

      To support new target platform (JBIDE-19776) which includes new Sapphire, here's a new proposal to update JBDS 9 / JBT 4.3 to require JDK 8 runtime.

      Proposal support matrix:

      • IDE installer will run wtih Java 6+ (but then user needs 8 to run it) [NO CHANGE]
      • IDE will ONLY run on Java 8+ [NEW for JBDS 9]
      • Server runtimes will run on existing JREs (from 4 - 9) [NO CHANGE]
      • QE actually does not test on 4 or 5, only 6+
      • Java 9 is "preview / smoketest" only, not supported yet

      To force users to use a JDK 8 runtime to run Eclipse Mars / JBDS 9, we need to change the Base component's Bundle-RequireExecutionEnvironment to require Java8 (not 7).

      Not sure how many plugins should be updated this way.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  akazakov Alexey Kazakov
                  Reporter:
                  nickboldt Nick Boldt
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: