Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-19500

warn/inform users running on non-compatilbe JVMs they are loosing out on features

    Details

      Description

      while reading https://developer.jboss.org/message/922318?et=watches.email.thread#922318 I got the idea that we could have a startup plugin that detects if the error log has lines matching:

      org.osgi.framework.BundleException: Could not resolve module: org.fusesource.ide.preferences [1447]
      
        Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"
      

      and there by tell them that they need to run JavaSE 1.7 to get this to work.

      This dialog should show up and have "don't disturb me again" for the specific bundle/feature that is filtered out.

      This is to warn those users that run ecipse with default javavm that still is java 6 on many installs.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  dazarov Daniel Azarov
                  Reporter:
                  maxandersen Max Rydahl Andersen
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  6 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: