Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-18584

New beans.xml should let the user choose the CDI version

    XMLWordPrintable

    Details

      Description

      The "New beans.xml" wizard generates the following content:

      <?xml version="1.0"?>
      <beans xmlns="http://java.sun.com/xml/ns/javaee"
       xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://jboss.org/schema/cdi/beans_1_0.xsd"/>
      

      but Java EE 7 includes CDI 1.1 which is like

      <beans xmlns="http://xmlns.jcp.org/xml/ns/javaee"
             xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
             xsi:schemaLocation="http://xmlns.jcp.org/xml/ns/javaee http://xmlns.jcp.org/xml/ns/javaee/beans_1_1.xsd"
             version="1.1" bean-discovery-mode="annotated">
      </beans>
      

      It would be nice if the wizard supported multiple versions of CDI (with the default value based on the CDI project facet ?)

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                scabanovich Viacheslav Kabanovich
                Reporter:
                xcoulon Xavier Coulon
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: