Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-17317

Update tern-java plug-ins in target platform 4.40.0.Beta2

    Details

    • Type: Feature Request
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 4.2.0.Alpha2, 4.2.0.Beta1
    • Fix Version/s: 4.2.0.Beta2
    • Component/s: target-platform
    • Labels:
      None

      Description

      Need to update the Tern.java plug-ins to version >= 0.2.0, build: 201405152124

      Reason:

      org.jboss.tools.jst.jsdt plug-ins require the latest Tern.java to compile.

      License and owner:

      • Root License is EPL. Owner is Angelo ZERR.
        • core
        • eclipse
          • tern.eclipse.ide.core - EPL (included into tern-feature below)
          • tern.eclipse.ide.jsdt - EPL (included into tern-jsdt-feature below)
          • tern.eclipse.ide.server.nodejs.core - EPL (included into tern-server-nodejs-feature below)
          • tern.eclipse.ide.server.nodejs.ui - EPL (included into tern-server-nodejs-feature below)
          • tern.eclipse.ide.server.nodejs.embed.linux.gtk.x86 - Supposed to be EPL but it is not included anywhere yet
            • node-v0.10.22-linux-x86.zip has several LICENSE files inside (download)
              • LICENSE
              • lib/node_modules/npm/LICENSE - The Artistic License 2.0
              • lib/node_modules/npm/node_modules/*/LICENSE
          • tern.eclipse.ide.server.nodejs.embed.linux.gtk.x86_64 - EPL (included into tern.eclipse.linux.gtk.x86.feature below)
            • node-v0.10.22-linux-x86_64.zip has several LICENSE files inside (download)
              • LICENSE
              • lib/node_modules/npm/LICENSE - The Artistic License 2.0
              • lib/node_modules/npm/node_modules/*/LICENSE
          • tern.eclipse.ide.server.nodejs.embed.macosx.cocoa.x86_64 - EPL (included into tern.eclipse.macosx.cocoa.x86_64.feature below)
            • node-v0.10.22-macosx-x86_64.zip has several LICENSE files inside (download)
              • LICENSE
              • lib/node_modules/npm - The Artistic License 2.0
              • lib/node_modules/npm/node_modules/*/LICENSE
          • tern.eclipse.ide.server.nodejs.embed.win32.win32.x86 - EPL (include into tern.eclipse.win32.win32.x86.feature below)
            • node-v0.10.22-win32-x86.zip has no LICENSE files inside (download)
          • tern.eclipse.ide.tools.core - EPL (included into tern.eclipse.ide.tools.feature below)
          • tern.eclipse.ide.tools.ui - EPL (included into tern.eclipse.ide.tools.feature below)
          • tern.eclipse.ide.ui - EPL (included into tern-feature below)
          • tern.eclipse - EPL (included into tern-feature below)
        • update-site

      Original repo:

      http://oss.opensagres.fr/tern.repository/0.2.0-SNAPSHOT/

      JBoss mirror:

      http://downloads.jboss.org/jbosstools/updates/requirements/tern.java-0.2.0.201404241609

      Sources:

      https://github.com/angelozerr/tern.java

      Affected projects:

      • jbosstools-jst

      Include in JBDS:

      No

      Type of dependency:

      distribution

      List of bundles added/removed:

      TBD: need to update PR to use features

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  nickboldt Nick Boldt
                  Reporter:
                  vrubezhny Victor Rubezhny
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: