Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-16082

Prevent JBoss Tools 4.1 and JBDS 7.x from installing into Luna due to platform/API incompatibilities

    Details

      Description

      We already know (from JBIDE-15639) that components like Arquillian, Forge, Server, and Hibernate will not compile with Luna dependencies due to the fact that the upstream projects on which they depend have changed in incompatible ways.

      Therefore, JBT 4.2 / JBDS 8 is being built to ONLY work with Luna.

      But the converse should be true, too: we don't want users installing JBT 4.1 / JBDS 7.x onto Luna and ending up with something that doesn't work, even if it can be installed that way.

      Solution:

      Update manifest.mf files to PREVENT installing key parts of JBT 4.1 / JBDS 7.x into Luna, so that no user will hit this problem.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  nickboldt Nick Boldt
                  Reporter:
                  nickboldt Nick Boldt
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: