Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-15639 Support running on Eclipse Luna platform
  3. JBIDE-16081

Aerogear.hybrid requires org.eclipse.debug.core [3.7.0,3.9.0) but Luna includes 3.9.0

    Details

      Description

      If org.jboss.tools.aerogear.hybrid.ios.core could be changed to depend on org.eclipse.debug.core [3.7.0,3.10.0) then it could be installed into Luna M3.

      1. fire up Eclipse Standard Luna M3 package (eclipse-standard-luna-M3-linux-gtk-x86_64.tar.gz). Help > Install new > ...

      uncheck "group by category" then select all features, and you'll get this:

      Cannot complete the install because of a conflicting dependency.
        Software being installed: JBoss Hybrid Mobile Application Development Tools (Experimental) 1.0.100.CR1-v20131116-0025-B52 (org.jboss.tools.aerogear.hybrid.feature.feature.group 1.0.100.CR1-v20131116-0025-B52)
        Software currently installed: Eclipse Standard/SDK 2.1.0.20131103-0830 (epp.package.standard 2.1.0.20131103-0830)
        Only one of the following can be installed at once: 
          Debug Core 3.9.0.v20131003-1341 (org.eclipse.debug.core 3.9.0.v20131003-1341)
          Debug Core 3.9.0.v20130819-1716 (org.eclipse.debug.core 3.9.0.v20130819-1716)
          Debug Core 3.9.0.v20130731-1644 (org.eclipse.debug.core 3.9.0.v20130731-1644)
          Debug Core 3.8.0.v20130514-0954 (org.eclipse.debug.core 3.8.0.v20130514-0954)
        Cannot satisfy dependency:
          From: Eclipse Standard/SDK 2.1.0.20131103-0830 (epp.package.standard 2.1.0.20131103-0830)
          To: org.eclipse.epp.package.standard.feature.feature.group [2.1.0.20131103-0830]
        Cannot satisfy dependency:
          From: Eclipse Standard/SDK Feature 2.1.0.20131103-0830 (org.eclipse.epp.package.standard.feature.feature.group 2.1.0.20131103-0830)
          To: org.eclipse.platform.feature.group [4.4.0.v20131030-2000]
        Cannot satisfy dependency:
          From: Eclipse Platform 4.4.0.v20131030-2000 (org.eclipse.platform.feature.group 4.4.0.v20131030-2000)
          To: org.eclipse.debug.core [3.9.0.v20131003-1341]
        Cannot satisfy dependency:
          From: JBoss Hybrid Mobile Application Development Tools (Experimental) 1.0.100.CR1-v20131116-0025-B52 (org.jboss.tools.aerogear.hybrid.feature.feature.group 1.0.100.CR1-v20131116-0025-B52)
          To: org.jboss.tools.aerogear.hybrid.ios.core [1.0.100.CR1-v20131116-0025-B52]
        Cannot satisfy dependency:
          From: JBoss Hybrid Mobile App. Dev. iOS Core 1.0.100.CR1-v20131116-0025-B52 (org.jboss.tools.aerogear.hybrid.ios.core 1.0.100.CR1-v20131116-0025-B52)
          To: bundle org.eclipse.debug.core [3.7.0,3.9.0)
      

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  gercan Gorkem Ercan
                  Reporter:
                  nickboldt Nick Boldt
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: