Tools (JBoss Tools)
  1. Tools (JBoss Tools)
  2. JBIDE-15396

cannot log into OpenShift (even though credentials are valid)

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved (View Workflow)
    • Priority: Critical Critical
    • Resolution: Done
    • Affects Version/s: 4.0.1.Final
    • Fix Version/s: 4.0.1.Final
    • Component/s: openshift
    • Labels:
      None
    • Workaround Description:

      upgrade to JBoss Tools 4.1 / JBDS 7

      Show
      upgrade to JBoss Tools 4.1 / JBDS 7
    • Steps to Reproduce:
      1. EXEC: create a new connection in OpenShift Explorer or launch OpenShift application wizard
      2. EXEC: when asked for credentials, create a new connection and provide valid credentials
      3. EXEC: in the credentials dialog: hit "Finish"

      Result:
      You're told that the credentials are not valid:

      Or see in https://bugzilla.redhat.com/show_bug.cgi?id=1003037

      Show
      EXEC: create a new connection in OpenShift Explorer or launch OpenShift application wizard EXEC: when asked for credentials, create a new connection and provide valid credentials EXEC: in the credentials dialog: hit "Finish" Result: You're told that the credentials are not valid: Or see in https://bugzilla.redhat.com/show_bug.cgi?id=1003037
    • Similar Issues:
      Show 10 results 

      Description

      You cannot log into OpenShift Online using JBoss Tools 4.0 / JBDS6 (JBDS7 and OpenShift Enterprise are not affected) any more.

        Issue Links

          Activity

          RH Bugzilla Integration
          added a comment -

          Dan McPherson <dmcphers@redhat.com> changed the Status of bug 1003037 from VERIFIED to CLOSED

          Show
          RH Bugzilla Integration
          added a comment - Dan McPherson <dmcphers@redhat.com> changed the Status of bug 1003037 from VERIFIED to CLOSED
          Andre Dietisheim
          added a comment - - edited

          just verified, with the fix in Origin one can currently log into OpenShift Online again using JBDS6.
          Thus closing as RESOLVED.

          Show
          Andre Dietisheim
          added a comment - - edited just verified, with the fix in Origin one can currently log into OpenShift Online again using JBDS6. Thus closing as RESOLVED.
          Denis Golovin
          added a comment -

          Set the fix version, please

          Show
          Denis Golovin
          added a comment - Set the fix version, please
          Andre Dietisheim
          added a comment -

          This was fixed in OpenShift Online, no changes in our code (this is a WATCHER issue). Online was verified to work on the 23.9. as commented above.

          Show
          Andre Dietisheim
          added a comment - This was fixed in OpenShift Online, no changes in our code (this is a WATCHER issue). Online was verified to work on the 23.9. as commented above.
          Andre Dietisheim
          added a comment -

          closing and resolving since fix-version is set

          Show
          Andre Dietisheim
          added a comment - closing and resolving since fix-version is set

            People

            • Assignee:
              Andre Dietisheim
              Reporter:
              Andre Dietisheim
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: