Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-13588

Openshift tools in JBT 4 require org.eclipse.egit.core [1.2.0,2.3.0), but the version of EGit in Juno SR2 is 2.3.0.201302130906

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 4.0.1.Final
    • Fix Version/s: 4.0.1.Final
    • Component/s: openshift
    • Labels:
      None

      Description

      Need to extend the upper bound in MANIFEST.MF and/or feature.xml files so Openshift tools in JBT 4 can depend on EGit <=2.3, not <2.3.

      [ERROR]   Software being installed: org.jboss.tools.openshift.egit.test 2.4.0.qualifier
      [ERROR]   Missing requirement: org.jboss.tools.openshift.egit.core 2.4.0.Final-v20130218-1429-B116 requires 'bundle org.eclipse.egit.core [1.2.0,2.3.0)' but it could not be found
      [ERROR]   Cannot satisfy dependency: org.jboss.tools.openshift.egit.test 2.4.0.qualifier depends on: bundle org.jboss.tools.openshift.egit.core 1.0.0
      

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                adietish André Dietisheim
                Reporter:
                nickboldt Nick Boldt
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: