Details

    • Type: Sub-task
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 3.3.1.Final
    • Fix Version/s: 3.3.2.Final
    • Component/s: openshift
    • Labels:
      None

      Description

      JBT 3.3.x Indigo target platform includes egit 1.2.

      org.jboss.tools.openshift.express.ui depends on org.eclipse.egit.ui;bundle-version="1.0.0", which means anyone with egit 2.x already installed won't be able to install the OpenShift tools:

      Cannot complete the install because of a conflicting dependency. Software being installed:
      JBoss OpenShift Tools 2.3.1.v20120715-0255-H145-Final (org.jboss.tools.openshift.express.feature.feature.group 2.3.1.v20120715-0255-H145-Final) 
      
      Software currently installed:
      Eclipse EGit 2.2.0.201212191850-r (org.eclipse.egit.feature.group 2.2.0.201212191850-r) 
      
       Only one of the following can be installed at once:
       Git Team Provider UI 2.2.0.201212191850-r (org.eclipse.egit.ui 2.2.0.201212191850-r) 
       Git Team Provider UI 1.2.0.201112121913 (org.eclipse.egit.ui 1.2.0.201112121913) 
      
      Because:
      
      org.jboss.tools.openshift.express.ui 2.3.1.v20120715-0255-H145-Final requires org.eclipse.egit.ui [1.0.0,2.0.0)
      

      Can openshift tools run w/ egit 2.x? Can we simply extend the version compliance ranges in the plugins to allow [1.0.0,3.0.0) ?

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  adietish André Dietisheim
                  Reporter:
                  nickboldt Nick Boldt
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: