Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-10415 build problems in Beta3
  3. JBIDE-11801

something is looking for GWT 2.6, but 2.5.1 is on TP and composite reqs site

    XMLWordPrintable

    Details

    • Type: Sub-task
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Rejected
    • Affects Version/s: 3.3.0.Beta3
    • Fix Version/s: 3.3.0.Beta3
    • Component/s: gwt, maven
    • Labels:
      None

      Description

      Any idea why the continuous build (cd ~/branches/jbosstools-3.3.0.Beta3/build; mvn clean install) thinks that it needs GWT 2.6 when we only have 2.5 in the TP and all the features/plugins I've checked either have NO version number requirement stated or want 2.5?

      [INFO] Resolving dependencies of MavenProject: org.jboss.tools.maven.features:org.jboss.tools.maven.gwt.feature:1.3.0-SNAPSHOT @ /mnt/hudson_workspace/workspace/jbosstools-3.3_stable_branch.continuous/sources/maven/features/org.jboss.tools.maven.gwt.feature/pom.xml
      [ERROR] Internal error: java.lang.RuntimeException: Could not download artifacts from any repository
      [ERROR] osgi.bundle,com.google.gdt.eclipse.platform,2.6.0.v201205021203-rel-r37
      [ERROR] osgi.bundle,com.google.gdt.eclipse.core,2.6.0.v201205021203-rel-r37
      [ERROR] osgi.bundle,com.google.gdt.eclipse.platform.e37,2.6.0.v201205021203-rel-r37
      [ERROR] osgi.bundle,com.google.gdt.eclipse.platform.shared,2.6.0.v201205021203-rel-r37
      [ERROR] osgi.bundle,com.google.gwt.eclipse.core,2.6.0.v201205021203-rel-r37
      [ERROR] -> [Help 1]
      org.apache.maven.InternalErrorException: Internal error: java.lang.RuntimeException: Could not download artifacts from any repository
         osgi.bundle,com.google.gdt.eclipse.platform,2.6.0.v201205021203-rel-r37
         osgi.bundle,com.google.gdt.eclipse.core,2.6.0.v201205021203-rel-r37
         osgi.bundle,com.google.gdt.eclipse.platform.e37,2.6.0.v201205021203-rel-r37
         osgi.bundle,com.google.gdt.eclipse.platform.shared,2.6.0.v201205021203-rel-r37
         osgi.bundle,com.google.gwt.eclipse.core,2.6.0.v201205021203-rel-r37
      

      http://hudson.qa.jboss.com/hudson/view/DevStudio/view/DevStudio_5.0.indigo/job/jbosstools-3.3_stable_branch.continuous/203/console

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                dgolovin Denis Golovin
                Reporter:
                nickboldt Nick Boldt
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: