Tools (JBoss Tools)
  1. Tools (JBoss Tools)
  2. JBIDE-11792

Incomplete deploy after undeploying and deleting a current deploy

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved (View Workflow)
    • Priority: Major Major
    • Resolution: Cannot Reproduce Bug
    • Affects Version/s: 3.2.2.Final
    • Fix Version/s: None
    • Component/s: maven, server
    • Labels:
      None
    • Environment:
      Eclipse 3.7.2 @ Mac OSX 10.7.3 (Lion), MacBook Air
    • Steps to Reproduce:

      1. Create a new JBoss Central/Spring MVC Project;
      2. Add a server instance (JBoss AS 7.1.1) inside Eclipse, and deploy this unmodified project template using the Project/Run As/Run on server way;
      3. Undeploy the project, and then deploy it again (i.e. undeploy using JBoss Management, then delete the exploded war-dirs, restart the server, and finally deploy as described above);

      Now the deployed WAR will not contain the contents of the webapp dir -> webapp won't run.

      Show
      1. Create a new JBoss Central/Spring MVC Project; 2. Add a server instance (JBoss AS 7.1.1) inside Eclipse, and deploy this unmodified project template using the Project/Run As/Run on server way; 3. Undeploy the project, and then deploy it again (i.e. undeploy using JBoss Management, then delete the exploded war-dirs, restart the server, and finally deploy as described above); Now the deployed WAR will not contain the contents of the webapp dir -> webapp won't run.
    • Similar Issues:
      Show 10 results 

      Description

      As I don't have time to reformulate myself, I just post what I've written on the forum earlier:

      I recently installed Eclipse 3.7.2 on Mac OSX 10.7.3 (Lion), together with the latest JBoss Tools package. As I am new to JBoss Tools (and Apache Maven that it's using in my projects) I decided to get familiar with it before going on with something serious. So I created a new JBoss Central/Spring MVC Project. After that I added a server instance (JBoss AS 7.1.1) inside Eclipse, and deployed this unmodified project template using the Project/Run As/Run on server way. This works perfectly! However, if I for some reason decide that I would like to undeploy the project, and then deploy it again (i.e. undeploy using JBoss Management, then delete the exploded war-dirs, restart the server, and finally deploy as described above), I end up with everything being deployed, EXCEPT for everything that is in the webapp directory (the one that's created by default in this project template). As a consequence, the web application won't run anymore.

      Now this is what I've tried without any success:

      • Restart Eclipse;
      • Delete every possible file in the JBoss AS directory, that could have something cached inside it;
      • Committed the whole project tree into GIT, in order to check whether Eclipse changes some config setting (it doesn't);
      • Various combinations of the above, together with a lot of other not-remembered steps ...

      I could add to this that what "solves" the problem is to refactor the project name to a new one; eg, if your project is called test, then refactor it to test2 and the problem is solved. When going back to the old name ("test" in the mentioned example), the problem will still be gone. This is not a nice solution however (especially if you have your project in git/svn etc) ... and the fact that it works makes the whole problem even more weird.

        Activity

        Max Rydahl Andersen
        added a comment -

        hmm - if you are undeploying via jboss management and delete the exploded war dirs then it is completely expected that JBoss Tools won't be able to do a proper deployment without a full publish or clean since you removed files without letting JBoss Tools know.

        Does a full publish or clean (right click on the module on the server and use the context menu) fix it ?

        Show
        Max Rydahl Andersen
        added a comment - hmm - if you are undeploying via jboss management and delete the exploded war dirs then it is completely expected that JBoss Tools won't be able to do a proper deployment without a full publish or clean since you removed files without letting JBoss Tools know. Does a full publish or clean (right click on the module on the server and use the context menu) fix it ?
        Max Rydahl Andersen
        added a comment -

        Ive followed the exact steps and I never end up with an incomplete deployment unless I actually remove things manually as you describe which then is not unexpected.

        Full publish, clean or remove/add again the module just works for me on.

        resolving since not seen any follow up.

        If you keep reproducing it then please try do full publish or clean and let us know how that goes.

        Show
        Max Rydahl Andersen
        added a comment - Ive followed the exact steps and I never end up with an incomplete deployment unless I actually remove things manually as you describe which then is not unexpected. Full publish, clean or remove/add again the module just works for me on. resolving since not seen any follow up. If you keep reproducing it then please try do full publish or clean and let us know how that goes.
        Lukas Kalinski
        added a comment -

        Sorry for a late reply (I was busy in other areas)!

        Anyway, doing a clean/full publish in JBoss tools works fine! Didn't consider using JBoss tools for this before (I just used the JBoss management tool in the browser).

        Thanks!

        Show
        Lukas Kalinski
        added a comment - Sorry for a late reply (I was busy in other areas)! Anyway, doing a clean/full publish in JBoss tools works fine! Didn't consider using JBoss tools for this before (I just used the JBoss management tool in the browser). Thanks!
        Max Rydahl Andersen
        added a comment -

        Thanks for letting us know - but yes, jbosstools both do deploy / undeploy so if you remove something it deployed its bound to be "confused" eventually

        Show
        Max Rydahl Andersen
        added a comment - Thanks for letting us know - but yes, jbosstools both do deploy / undeploy so if you remove something it deployed its bound to be "confused" eventually

          People

          • Assignee:
            Rob Stryker
            Reporter:
            Lukas Kalinski
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: