Details

    • Type: Bug Bug
    • Status: Closed Closed (View Workflow)
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: 3.3.0.M5
    • Fix Version/s: 3.3.0.Beta1
    • Environment:
      Linux 3.1.6-gentoo #1 SMP x86_64 Intel(R) Core(TM) i7-2720QM CPU @ 2.20GHz GenuineIntel GNU/Linux
      IcedTea JDK 6.1.10.4
      eclipse-jee-indigo-SR1-linux-gtk-x86_64.tar.gz
    • Steps to Reproduce:

      Install eclipse-jee-indigo-SR1-linux-gtk-x86_64.tar.gz and update JBoss Tools from http://download.jboss.org/jbosstools/updates/development/indigo/ .
      1)
      Open JBoss Central and install the kichensink example. Open the pom.xml and select the xml view. Put pointer over the red underlined plugin tag at the maven compiler plugin definition. Select in the popup discover m2e connectors.

      2)
      Window->Open Preferences->Maven->Discovery->Open Catalog

      Show
      Install eclipse-jee-indigo-SR1-linux-gtk-x86_64.tar.gz and update JBoss Tools from http://download.jboss.org/jbosstools/updates/development/indigo/ . 1) Open JBoss Central and install the kichensink example. Open the pom.xml and select the xml view. Put pointer over the red underlined plugin tag at the maven compiler plugin definition. Select in the popup discover m2e connectors. 2) Window->Open Preferences->Maven->Discovery->Open Catalog
    • Similar Issues:
      Show 10 results 

      Description

      I followed the guide on https://community.jboss.org/community/tools/blog/2011/12/23/jboss-tools-m5-is-coming-to-town

      I installed eclipse-jee-indigo-SR1-linux-gtk-x86_64.tar.gz and update JBoss Tools from http://download.jboss.org/jbosstools/updates/development/indigo/ . I started with the Kitchensink example on the "Jboss Central". I opened the pom.xml and put the pointer over the plugin tag of the maven-compiler-plugin. An Error/Quickfix pop's up (snip snap):

      Plugin execution not covered by lifecycle configuration: org.apache.maven.plugins:maven-compiler-plugin:2.3.1:compile (execution: default-compile, phase: compile)

      2 Quickfixes avaiulable:
      -Permanently mark goal bla bla bla
      -Discover new m2e connectors

      CoreException: Could not calculate build plan ....

      I choose "Discover new m2e connectors" and got an error:

      "Discovery completed without finding any extensions. Please check your network connection and try again."

      Very confusing Message, because my network connection is ok. It is impossible to discover m2e connectors under Preferences->maven-> Discovery->Open Catalog. The Catalog URL is http://download.eclipse.org/technology/m2e/discovery/directory.xml

      When I install m2e without Jbosstools Help->install new software, m2e is able to discover connectors.

        Issue Links

          Activity

          Denis Golovin
          added a comment -

          I'm trying to replicate this on the same platform and everything just works I did see this error before as it reported here JBDS-1519.

          @Jochen
          What was installed initially from JBoss Tools Update site?

          Show
          Denis Golovin
          added a comment - I'm trying to replicate this on the same platform and everything just works I did see this error before as it reported here JBDS-1519. @Jochen What was installed initially from JBoss Tools Update site?
          Max Rydahl Andersen
          added a comment -

          assign to Denis since you are trying to reproduce.

          If taking too long and no further evidence pass it on to QE for a try.

          Show
          Max Rydahl Andersen
          added a comment - assign to Denis since you are trying to reproduce. If taking too long and no further evidence pass it on to QE for a try.
          Jochen Buchholz
          added a comment -

          @Dennis
          I selected everything on the JBoss Tools update site installation.

          Show
          Jochen Buchholz
          added a comment - @Dennis I selected everything on the JBoss Tools update site installation.
          Denis Golovin
          added a comment -

          Tried to replicate it again and it is the same, no problems.
          fixing for now to let QA verify it

          Show
          Denis Golovin
          added a comment - Tried to replicate it again and it is the same, no problems. fixing for now to let QA verify it
          Vlado Pakan
          added a comment -

          Verified on JBT 3.3.0.v20120224-2315-H93-Beta1.

          No problems found.

          If problem still persist reopen this Jira.

          Show
          Vlado Pakan
          added a comment - Verified on JBT 3.3.0.v20120224-2315-H93-Beta1. No problems found. If problem still persist reopen this Jira.

            People

            • Assignee:
              Denis Golovin
              Reporter:
              Jochen Buchholz
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: