Tools (JBoss Tools)
  1. Tools (JBoss Tools)
  2. JBIDE-10048

Reorganize JBoss Tools features into new categories (was All JBoss Tools is very confusing)

    Details

    • Type: Bug Bug
    • Status: Closed Closed (View Workflow)
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: 3.3.0.M4
    • Fix Version/s: 3.3.0.M5
    • Component/s: updatesite
    • Labels:
      None
    • Similar Issues:
      Show 10 results 

      Description

      All JBoss Tools is very confusing.

      it is unclear to the novice user what checkboxes should be checked.

      I believe the right "subset" is

      • All JBoss Tools
      • Application Development
      • Maven Support
      • Web and Java EE Development

      Those 4 should be "All JBoss Tools" or "the Right Set of JBoss Tools" for the average user.

        Issue Links

          Activity

          Nick Boldt
          added a comment -

          Well, we've changed "All" to "Abridged" (JBIDE-10029) ... is that better?

          Show
          Nick Boldt
          added a comment - Well, we've changed "All" to "Abridged" ( JBIDE-10029 ) ... is that better?
          Burr Sutter
          added a comment -

          and we need to eliminate some categories that just overlap.

          like what is the difference between Application development and Web development?
          and Cloud is just deltacloud now, not the Openshift Express which is part of something else.
          and I always want Maven so that should be part of "abridged".

          Show
          Burr Sutter
          added a comment - and we need to eliminate some categories that just overlap. like what is the difference between Application development and Web development? and Cloud is just deltacloud now, not the Openshift Express which is part of something else. and I always want Maven so that should be part of "abridged".
          Jim Tyrrell
          added a comment -

          I would agree, when looking at this list it is totally overwhelming, things overlap, etc. I would say possibly the right thing to do is target the projects with the right kinds of bundling.
          jEE Developement
          SOA Development
          Drools/Rules Development
          Portal Development
          Business Process Development

          Thoughts on the above....

          Show
          Jim Tyrrell
          added a comment - I would agree, when looking at this list it is totally overwhelming, things overlap, etc. I would say possibly the right thing to do is target the projects with the right kinds of bundling. jEE Developement SOA Development Drools/Rules Development Portal Development Business Process Development Thoughts on the above....
          Nick Boldt
          added a comment - - edited

          @Burr:

          Openshift Express is now in the Cloud category - it was split in JBIDE-10013:

          http://download.jboss.org/jbosstools/updates/nightly/trunk/

          When ya'll achieve quorum, please list for me which features you want in which categories, eg:

           AbridgedTools
             Maven
             ...
           CloudTools
             OpenshiftExpress
             DeltaCloud
           Business Process Development
             ...
          

          Note too that there are not 1 but 5 sites to look at:

          JBoss Tools - Core:
          http://download.jboss.org/jbosstools/updates/nightly/trunk/

          JBoss Tools - SOA Tooling:
          http://download.jboss.org/jbosstools/updates/nightly/soa-tooling/trunk/

          JBDS - Core / Product:
          http://www.qa.jboss.com/binaries/RHDS/builds/staging/devstudio-5.0_trunk.updatesite/product/
          http://www.qa.jboss.com/binaries/RHDS/builds/staging/devstudio-5.0_trunk.product/updates/nightly/trunk/

          JBDS - SOA Tooling:
          http://www.qa.jboss.com/binaries/RHDS/builds/staging/devstudio-5.0_trunk.soa-tooling.updatesite/product-soa/

          JBDS Extras:
          http://www.qa.jboss.com/binaries/RHDS/builds/staging/devstudio-5.0_trunk.updatesite/extras/

          Show
          Nick Boldt
          added a comment - - edited @Burr: Openshift Express is now in the Cloud category - it was split in JBIDE-10013 : http://download.jboss.org/jbosstools/updates/nightly/trunk/ When ya'll achieve quorum, please list for me which features you want in which categories, eg: AbridgedTools Maven ... CloudTools OpenshiftExpress DeltaCloud Business Process Development ... Note too that there are not 1 but 5 sites to look at: JBoss Tools - Core: http://download.jboss.org/jbosstools/updates/nightly/trunk/ JBoss Tools - SOA Tooling: http://download.jboss.org/jbosstools/updates/nightly/soa-tooling/trunk/ JBDS - Core / Product: http://www.qa.jboss.com/binaries/RHDS/builds/staging/devstudio-5.0_trunk.updatesite/product/ http://www.qa.jboss.com/binaries/RHDS/builds/staging/devstudio-5.0_trunk.product/updates/nightly/trunk/ JBDS - SOA Tooling: http://www.qa.jboss.com/binaries/RHDS/builds/staging/devstudio-5.0_trunk.soa-tooling.updatesite/product-soa/ JBDS Extras: http://www.qa.jboss.com/binaries/RHDS/builds/staging/devstudio-5.0_trunk.updatesite/extras/
          Burr Sutter
          added a comment -

          For:
          http://download.jboss.org/jbosstools/updates/nightly/trunk/

          Based on a review of all the individual features listed across the various categories, I propose having just two categories:

          • Core
            • everything not in Incubating below
          • Incubating
            • BIRT
            • DeltaCloud
            • AS/eGit Integration
            • GWT Integration

          The goal is to offer single-click installation, less confusion, for the most common usage pattern - JBoss-based Java EE development. There are very few features/plugins that fall outside of the "Java EE" usage scenario, two few to separately categorize.

          Show
          Burr Sutter
          added a comment - For: http://download.jboss.org/jbosstools/updates/nightly/trunk/ Based on a review of all the individual features listed across the various categories, I propose having just two categories: Core everything not in Incubating below Incubating BIRT DeltaCloud AS/eGit Integration GWT Integration The goal is to offer single-click installation, less confusion, for the most common usage pattern - JBoss-based Java EE development. There are very few features/plugins that fall outside of the "Java EE" usage scenario, two few to separately categorize.
          Nick Boldt
          added a comment -

          What about openshift and central? Surely they're Incubating too?

          Please have a look at the JBoss Tools - SOA Tooling site next:

          http://download.jboss.org/jbosstools/updates/nightly/soa-tooling/trunk/

          Show
          Nick Boldt
          added a comment - What about openshift and central? Surely they're Incubating too? Please have a look at the JBoss Tools - SOA Tooling site next: http://download.jboss.org/jbosstools/updates/nightly/soa-tooling/trunk/
          Burr Sutter
          added a comment -

          OpenShift and Central are both expected to be 'first class citizens' of JBoss Tools 3.3.Final and JBDS 5.0 GA.

          Show
          Burr Sutter
          added a comment - OpenShift and Central are both expected to be 'first class citizens' of JBoss Tools 3.3.Final and JBDS 5.0 GA.
          Burr Sutter
          added a comment -

          Concerning SOA Tools Trunk - http://download.jboss.org/jbosstools/updates/nightly/soa-tooling/trunk/

          the only thing that I can say at this moment is that it should not have a "JBoss Application Development" category.

          Show
          Burr Sutter
          added a comment - Concerning SOA Tools Trunk - http://download.jboss.org/jbosstools/updates/nightly/soa-tooling/trunk/ the only thing that I can say at this moment is that it should not have a "JBoss Application Development" category.
          Burr Sutter
          added a comment -

          on JBoss Tools M4a - http://download.jboss.org/jbosstools/updates/JBossTools-3.3.0.M4a/

          "Abridged JBoss Tools 3.3" becomes "Core JBoss Tools 3.3", right?

          Show
          Burr Sutter
          added a comment - on JBoss Tools M4a - http://download.jboss.org/jbosstools/updates/JBossTools-3.3.0.M4a/ "Abridged JBoss Tools 3.3" becomes "Core JBoss Tools 3.3", right?
          Nick Boldt
          added a comment -

          OK, so where should the features now in "GeneralTools" / "JBoss Application Development" be moved?

          SOA Tools? Data Tools?

          Or should we just have the same two categories as the Core site, ie., "SOA Tooling" and "Incubating" (where Incubating could be empty) ?

          Show
          Nick Boldt
          added a comment - OK, so where should the features now in "GeneralTools" / "JBoss Application Development" be moved? SOA Tools? Data Tools? Or should we just have the same two categories as the Core site, ie., "SOA Tooling" and "Incubating" (where Incubating could be empty) ?
          Max Rydahl Andersen
          added a comment -

          dont see anything related to JBDS here so renamed the issue.

          Show
          Max Rydahl Andersen
          added a comment - dont see anything related to JBDS here so renamed the issue.
          Max Rydahl Andersen
          added a comment -

          Core/incubating seperation is broken from day one since that is not true for many of these and doesn't relate to how users install/set it up.

          Abridged JBoss Tools is there for an easy installation, the one you say "single-click" but removing the further categorization changes how it looks when merged with other updatesites in p2 UI thus lets just keep the categorization.

          btw. why don't you want an "JBoss Application Development" ? this is exactly what that category is about.

          Note, the content of this becomes more clear when you add in SOA which adds even more categorization.

          Thus lets just keep this simple and add maven stuff into Abridged (need to check with Fred if all could/should move) and keep the categorization so it matches with the other sites used.

          Show
          Max Rydahl Andersen
          added a comment - Core/incubating seperation is broken from day one since that is not true for many of these and doesn't relate to how users install/set it up. Abridged JBoss Tools is there for an easy installation, the one you say "single-click" but removing the further categorization changes how it looks when merged with other updatesites in p2 UI thus lets just keep the categorization. btw. why don't you want an "JBoss Application Development" ? this is exactly what that category is about. Note, the content of this becomes more clear when you add in SOA which adds even more categorization. Thus lets just keep this simple and add maven stuff into Abridged (need to check with Fred if all could/should move) and keep the categorization so it matches with the other sites used.
          Max Rydahl Andersen
          added a comment -

          p.s. the easy to install for jboss tools is to use eclipse marketplace.

          Show
          Max Rydahl Andersen
          added a comment - p.s. the easy to install for jboss tools is to use eclipse marketplace.
          Nick Boldt
          added a comment -

          Related to Doc question about recatg'zing.

          Show
          Nick Boldt
          added a comment - Related to Doc question about recatg'zing.
          Burr Sutter
          added a comment -

          max, are you saying the majority of our JBoss Tools "installations" are coming from Eclipse Marketplace instead of our updatesite? If so, then the complexity and confusion caused by having to pick up to 4 overlapping categories is likely OK-as nobody actually sees these URLs/uses these update sites.

          If in fact a large number of people use this updatesite then it should be much easier to determine what needs to be installed. I suggest that most people want most features/plugins - they want "JBoss Tools" without having to spend too much time thinking about what pieces are vital.

          Show
          Burr Sutter
          added a comment - max, are you saying the majority of our JBoss Tools "installations" are coming from Eclipse Marketplace instead of our updatesite? If so, then the complexity and confusion caused by having to pick up to 4 overlapping categories is likely OK-as nobody actually sees these URLs/uses these update sites. If in fact a large number of people use this updatesite then it should be much easier to determine what needs to be installed. I suggest that most people want most features/plugins - they want "JBoss Tools" without having to spend too much time thinking about what pieces are vital.
          Max Rydahl Andersen
          added a comment -

          And making the "Abridged JBoss Tools" contain the maven parts that are the only one missing in there is not enough for you ?

          If we put everything in one long list its even more confusing for those who want just parts of it (i.e. alot just installs Hibernate Tools + AS Tools)

          Show
          Max Rydahl Andersen
          added a comment - And making the "Abridged JBoss Tools" contain the maven parts that are the only one missing in there is not enough for you ? If we put everything in one long list its even more confusing for those who want just parts of it (i.e. alot just installs Hibernate Tools + AS Tools)
          Fred Bricon
          added a comment -

          Of course I strongly believe that the Maven stuff should be sitting in the Abridged / Core / Whatever Main category you can find, however I would probably keep those largely untested (or troublesome), experimental Maven configurators that are JBoss packaging (SAR support for now) and JAX-RS in the Maven Category only.

          Show
          Fred Bricon
          added a comment - Of course I strongly believe that the Maven stuff should be sitting in the Abridged / Core / Whatever Main category you can find, however I would probably keep those largely untested (or troublesome), experimental Maven configurators that are JBoss packaging (SAR support for now) and JAX-RS in the Maven Category only.
          Burr Sutter
          added a comment -

          For the Maven features that are not due to "GA" with JBoss Tools 3.3.Final then I think those can stay in another category - or just move to the proposed "incubating". However, there are some aspects of Maven that are mission critical to JBoss Central, Forge, etc. Those need to be easily selectable with a general JBoss Tools installation.

          My primary goal is to make it dead simple for the average user to say "Give me everything I need" for:

          • EE6 & AS7
          • JBoss Central
          • Archetypes
          • Quickstarts

          Abridged JBoss Tools does not properly capture this idea, but only having two categories does ("real stuff" vs "experimental stuff").

          Show
          Burr Sutter
          added a comment - For the Maven features that are not due to "GA" with JBoss Tools 3.3.Final then I think those can stay in another category - or just move to the proposed "incubating". However, there are some aspects of Maven that are mission critical to JBoss Central, Forge, etc. Those need to be easily selectable with a general JBoss Tools installation. My primary goal is to make it dead simple for the average user to say "Give me everything I need" for: EE6 & AS7 JBoss Central Archetypes Quickstarts Abridged JBoss Tools does not properly capture this idea, but only having two categories does ("real stuff" vs "experimental stuff").
          Nick Boldt
          added a comment -

          Can we be explicitly clear as to which chunks of Maven you want added to Abridged and which can stay in just the Maven category?

          @Fred, @Burr, please list the features (by feature ID) which are mission critical vs. those which are not.

          Show
          Nick Boldt
          added a comment - Can we be explicitly clear as to which chunks of Maven you want added to Abridged and which can stay in just the Maven category? @Fred, @Burr, please list the features (by feature ID) which are mission critical vs. those which are not.
          Max Rydahl Andersen
          added a comment -

          Burr - Abridged tools is the first element shown and the rest is for those doing individual installs.

          Show
          Max Rydahl Andersen
          added a comment - Burr - Abridged tools is the first element shown and the rest is for those doing individual installs.
          Max Rydahl Andersen
          added a comment -

          if neither "Abridged" nor "All" doesn't work then please suggest another word that starts with an A or some other way to get it to show up on top.

          Note that we are also coming out with Bugzilla/Jira integrations which aren't experiemental but also shouldn't be installed.
          Similar is that we are to start pushing -source bundles for these jars - thats also not something that fits into "real" vs "experiemental".

          The p2 updatesite UI just don't handle this well which is why things like JBoss Central and Eclipse MarketPlace have been born.

          Show
          Max Rydahl Andersen
          added a comment - if neither "Abridged" nor "All" doesn't work then please suggest another word that starts with an A or some other way to get it to show up on top. Note that we are also coming out with Bugzilla/Jira integrations which aren't experiemental but also shouldn't be installed. Similar is that we are to start pushing -source bundles for these jars - thats also not something that fits into "real" vs "experiemental". The p2 updatesite UI just don't handle this well which is why things like JBoss Central and Eclipse MarketPlace have been born.
          Nick Boldt
          added a comment -

          Suggestion:

          Abridged (or Core) JBoss Tools 
          Incubating (or Experimental) JBoss Tools
          JBoss _____ Tools/Development/Services
          
          (where ___ = Data, SOA, Web/JEE, etc.)
          
          Show
          Nick Boldt
          added a comment - Suggestion: Abridged (or Core) JBoss Tools Incubating (or Experimental) JBoss Tools JBoss _____ Tools/Development/Services (where ___ = Data, SOA, Web/JEE, etc.)
          Burr Sutter
          added a comment -

          The problem with the previous "All" was that it left out some of the most important pieces, specifically the Maven.

          If "All" == "Everything I need to use JBoss Central and to basically get started with EE6 dev on AS7" then I think All is workable.

          I am also OK with "Core" as that suggests that it is the minimum set of tools for getting started with EE6 Dev on AS7 + OpenShift.

          Show
          Burr Sutter
          added a comment - The problem with the previous "All" was that it left out some of the most important pieces, specifically the Maven. If "All" == "Everything I need to use JBoss Central and to basically get started with EE6 dev on AS7" then I think All is workable. I am also OK with "Core" as that suggests that it is the minimum set of tools for getting started with EE6 Dev on AS7 + OpenShift.
          Max Rydahl Andersen
          added a comment -

          All also leaves out Birt, GWT, DeltaCloud, Teiid, modeshape, 3rd party integrations and more. So its not all and never will be.

          But if moving Abridged back to All makes this discussion go away and you think this will not continue to create confusion then I'm ok with.

          Core I simply do not want since we got other parts of jboss tools called Core which is actually Core and not this "Bundle of bigger things"

          Again, this really isn't the place we should spend time on - we should be looking at jboss central to software-update page instead.

          Show
          Max Rydahl Andersen
          added a comment - All also leaves out Birt, GWT, DeltaCloud, Teiid, modeshape, 3rd party integrations and more. So its not all and never will be. But if moving Abridged back to All makes this discussion go away and you think this will not continue to create confusion then I'm ok with. Core I simply do not want since we got other parts of jboss tools called Core which is actually Core and not this "Bundle of bigger things" Again, this really isn't the place we should spend time on - we should be looking at jboss central to software-update page instead.
          Burr Sutter
          added a comment -

          Unfortunately the end-user will never see JBoss Central because it is very easy to not select based on the current categorization scheme.

          Based on the M4 Category names:
          Abridged
          JBoss Application Development
          JBoss Business Intelligence
          JBoss Cloud Tools
          JBoss Data Services
          JBoss Maven Support
          JBoss Web and Java EE Development

          I, the end-user, would likely select "JBoss Web and Java EE Development" or perhaps "JBoss Application Development".

          Abridged sounds strange so I would skip that because what I want to do is "build EE apps for JBoss" primarily.

          All used to work before it did not contain "everything I typically need", basically Maven was missing and it is mission critical to the whole experience.

          Show
          Burr Sutter
          added a comment - Unfortunately the end-user will never see JBoss Central because it is very easy to not select based on the current categorization scheme. Based on the M4 Category names: Abridged JBoss Application Development JBoss Business Intelligence JBoss Cloud Tools JBoss Data Services JBoss Maven Support JBoss Web and Java EE Development I, the end-user, would likely select "JBoss Web and Java EE Development" or perhaps "JBoss Application Development". Abridged sounds strange so I would skip that because what I want to do is "build EE apps for JBoss" primarily. All used to work before it did not contain "everything I typically need", basically Maven was missing and it is mission critical to the whole experience.
          Nick Boldt
          added a comment -

          Are we any closer to knowing what you'd like for M5?

          Please list for me either the end state you'd like to see, or the changes you'd like made. I find it near-impossible to digest work items from email threads and jira discussions. It's a lot of "I'd like to see..." and "I think we..." but no "It should be this:" or "Change this to that" or even "s/old-and-wrong/new-and-better/".

          Show
          Nick Boldt
          added a comment - Are we any closer to knowing what you'd like for M5? Please list for me either the end state you'd like to see, or the changes you'd like made. I find it near-impossible to digest work items from email threads and jira discussions. It's a lot of "I'd like to see..." and "I think we..." but no "It should be this:" or "Change this to that" or even "s/old-and-wrong/new-and-better/".
          Nick Boldt
          added a comment -

          Bounce to @Burr for feedback.

          Show
          Nick Boldt
          added a comment - Bounce to @Burr for feedback.
          Max Rydahl Andersen
          added a comment -

          Before JBoss Central Update/Install functionality is in place this doesn't change - we are good for now.

          Show
          Max Rydahl Andersen
          added a comment - Before JBoss Central Update/Install functionality is in place this doesn't change - we are good for now.
          Nick Boldt
          added a comment - - edited

          I've added these maven features into the "AbridgedTools" category, because someone had asked that the be part of the "one-click" install:

          <feature url="features/org.jboss.tools.maven.seam.feature_0.0.0.jar" id="org.jboss.tools.maven.seam.feature" version="0.0.0">
          <feature url="features/org.jboss.tools.maven.jsf.feature_0.0.0.jar" id="org.jboss.tools.maven.jsf.feature" version="0.0.0">
          <feature url="features/org.jboss.tools.maven.cdi.feature_0.0.0.jar" id="org.jboss.tools.maven.cdi.feature" version="0.0.0">
          <feature url="features/org.jboss.tools.maven.hibernate.feature_0.0.0.jar" id="org.jboss.tools.maven.hibernate.feature" version="0.0.0">
          <feature url="features/org.jboss.tools.maven.portlet.feature_0.0.0.jar" id="org.jboss.tools.maven.portlet.feature" version="0.0.0">
          <feature url="features/org.jboss.tools.maven.project.examples.feature_0.0.0.jar" id="org.jboss.tools.maven.project.examples.feature" version="0.0.0">
          

          But I'm not including these as they've so far been deemed "incubating", I believe:

          <feature url="features/org.jboss.tools.maven.jaxrs.feature_0.0.0.jar" id="org.jboss.tools.maven.jaxrs.feature" version="0.0.0">
          <feature url="features/org.jboss.tools.maven.jbosspackaging.feature_0.0.0.jar" id="org.jboss.tools.maven.jbosspackaging.feature" version="0.0.0">
          

          You can review this file to see which features are either uncategorized or are only in a category OTHER than the "AbridgedTools" category.

          http://anonsvn.jboss.org/repos/jbosstools/trunk/build/aggregate/site/site.xml

          Should anything else need to be tweaked here, don't hesitate to ask.

          You can also review the categorization scheme by looking at this site in Eclipse, or in a browser:

          http://download.jboss.org/jbosstools/updates/nightly/trunk/

          Show
          Nick Boldt
          added a comment - - edited I've added these maven features into the "AbridgedTools" category, because someone had asked that the be part of the "one-click" install: <feature url= "features/org.jboss.tools.maven.seam.feature_0.0.0.jar" id= "org.jboss.tools.maven.seam.feature" version= "0.0.0" > <feature url= "features/org.jboss.tools.maven.jsf.feature_0.0.0.jar" id= "org.jboss.tools.maven.jsf.feature" version= "0.0.0" > <feature url= "features/org.jboss.tools.maven.cdi.feature_0.0.0.jar" id= "org.jboss.tools.maven.cdi.feature" version= "0.0.0" > <feature url= "features/org.jboss.tools.maven.hibernate.feature_0.0.0.jar" id= "org.jboss.tools.maven.hibernate.feature" version= "0.0.0" > <feature url= "features/org.jboss.tools.maven.portlet.feature_0.0.0.jar" id= "org.jboss.tools.maven.portlet.feature" version= "0.0.0" > <feature url= "features/org.jboss.tools.maven.project.examples.feature_0.0.0.jar" id= "org.jboss.tools.maven.project.examples.feature" version= "0.0.0" > But I'm not including these as they've so far been deemed "incubating", I believe: <feature url= "features/org.jboss.tools.maven.jaxrs.feature_0.0.0.jar" id= "org.jboss.tools.maven.jaxrs.feature" version= "0.0.0" > <feature url= "features/org.jboss.tools.maven.jbosspackaging.feature_0.0.0.jar" id= "org.jboss.tools.maven.jbosspackaging.feature" version= "0.0.0" > You can review this file to see which features are either uncategorized or are only in a category OTHER than the "AbridgedTools" category. http://anonsvn.jboss.org/repos/jbosstools/trunk/build/aggregate/site/site.xml Should anything else need to be tweaked here, don't hesitate to ask. You can also review the categorization scheme by looking at this site in Eclipse, or in a browser: http://download.jboss.org/jbosstools/updates/nightly/trunk/
          Burr Sutter
          added a comment -

          So this all started with an end-user, asked to install JBoss Tools, went to the update site and selected only "All JBoss Tools" and then discovered, much to his surprise that several things were missing.

          Now, I have another end-user, who when asked to install JBoss Tools, went to the update site and selected everything but "Abridged" because he wanted everything, just the subset. Therefore, he checked all the other boxes and found, much to his surprise that several things were missing.

          So, does Abridged now include "Everything you really need minus the experimental stuff"? Then it is back to being "All".

          In general, competing Eclipse tool distributions do not have this many categories and the confusion. You either want the bundle (e.g. JBoss Tools) or not.

          Show
          Burr Sutter
          added a comment - So this all started with an end-user, asked to install JBoss Tools, went to the update site and selected only "All JBoss Tools" and then discovered, much to his surprise that several things were missing. Now, I have another end-user, who when asked to install JBoss Tools, went to the update site and selected everything but "Abridged" because he wanted everything, just the subset. Therefore, he checked all the other boxes and found, much to his surprise that several things were missing. So, does Abridged now include "Everything you really need minus the experimental stuff"? Then it is back to being "All". In general, competing Eclipse tool distributions do not have this many categories and the confusion. You either want the bundle (e.g. JBoss Tools) or not.
          Nick Boldt
          added a comment - - edited

          Yes, but we include enough disparate stuff that we're basically another Indigo - and Indigo has dozens of categories of tools. There's no "install everything" button for Indigo either, unless you include the "Select All" button in the UI itself.

          Maybe we just need to teach users how to use the p2 user interface? Should I provide a screenshot showing the "Select All" button highlighted on the install page [1] ?

          [1] https://www.jboss.org/tools/download/installation/update_3_3

          Show
          Nick Boldt
          added a comment - - edited Yes, but we include enough disparate stuff that we're basically another Indigo - and Indigo has dozens of categories of tools. There's no "install everything" button for Indigo either, unless you include the "Select All" button in the UI itself. Maybe we just need to teach users how to use the p2 user interface? Should I provide a screenshot showing the "Select All" button highlighted on the install page [1] ? [1] https://www.jboss.org/tools/download/installation/update_3_3
          Max Rydahl Andersen
          added a comment -

          Please tell them to use Eclipse Marketplace - just one category.

          And please tell which competing installation site has an "All" category in comparison with same amount of functionality ?

          Note, if they selected everything but Abridged they should get everything - if that is not the case something is wrong.

          Nick, can you double check there arent features that are only in abridged ?

          Show
          Max Rydahl Andersen
          added a comment - Please tell them to use Eclipse Marketplace - just one category. And please tell which competing installation site has an "All" category in comparison with same amount of functionality ? Note, if they selected everything but Abridged they should get everything - if that is not the case something is wrong. Nick, can you double check there arent features that are only in abridged ?
          Burr Sutter
          added a comment -

          Does Marketplace give the end-user 3.3.M4? Or will it M5?

          Show
          Burr Sutter
          added a comment - Does Marketplace give the end-user 3.3.M4? Or will it M5?
          Fred Bricon
          added a comment -

          Most likely, Max will update the Eclipse Marketplace entry to point to M5 as soon as it's out.

          Show
          Fred Bricon
          added a comment - Most likely, Max will update the Eclipse Marketplace entry to point to M5 as soon as it's out.
          Nick Boldt
          added a comment -

          @Max:

          Based on a quick read of http://download.jboss.org/jbosstools/updates/nightly/core/trunk/ I see a number of features that are ONLY in Abridged:

          org.jboss.tools.central.feature
          org.jboss.tools.common.jdt.feature
          org.jboss.tools.common.mylyn.feature
          org.jboss.tools.community.central.feature
          org.jboss.tools.runtime.as.detector.feature
          org.jboss.tools.runtime.core.feature
          org.jboss.tools.runtime.feature
          org.jboss.tools.runtime.seam.detector.feature
          org.jboss.tools.usage.feature

          You can also see what features are NOT in Abridged but in another category, and which features are uncategorized.

          Want something changed? Ask and ye shall receive. Commit your own fix [1] and ye shall receive faster.

          [1] https://svn.jboss.org/repos/jbosstools/trunk/build/aggregate/site/site.xml

          Show
          Nick Boldt
          added a comment - @Max: Based on a quick read of http://download.jboss.org/jbosstools/updates/nightly/core/trunk/ I see a number of features that are ONLY in Abridged : org.jboss.tools.central.feature org.jboss.tools.common.jdt.feature org.jboss.tools.common.mylyn.feature org.jboss.tools.community.central.feature org.jboss.tools.runtime.as.detector.feature org.jboss.tools.runtime.core.feature org.jboss.tools.runtime.feature org.jboss.tools.runtime.seam.detector.feature org.jboss.tools.usage.feature You can also see what features are NOT in Abridged but in another category, and which features are uncategorized. Want something changed? Ask and ye shall receive. Commit your own fix [1] and ye shall receive faster. [1] https://svn.jboss.org/repos/jbosstools/trunk/build/aggregate/site/site.xml
          Nick Boldt
          added a comment -

          @Burr:

          Marketplace points at the latest development milestone site [2] so it updates automagically when I publish an updated milestone to the site.

          [2] http://download.jboss.org/jbosstools/updates/development/indigo/

          Show
          Nick Boldt
          added a comment - @Burr: Marketplace points at the latest development milestone site [2] so it updates automagically when I publish an updated milestone to the site. [2] http://download.jboss.org/jbosstools/updates/development/indigo/
          Burr Sutter
          added a comment -

          Thanks!

          So we can tell users:
          a) Eclipse Marketplace for using your existing Eclipse - avoid our update site
          b) JBDS Free Download if you do not have Indigo already installed.

          I would like to see us "demote" the update site instructions and promote marketplace on this page.
          http://www.jboss.org/tools/download.html

          Granted, the expert user can navigate around ours and others update sites, picking and choosing the specific features they want. Here, I am mostly worried about the person trying out JBoss Tools for the very first time.

          Show
          Burr Sutter
          added a comment - Thanks! So we can tell users: a) Eclipse Marketplace for using your existing Eclipse - avoid our update site b) JBDS Free Download if you do not have Indigo already installed. I would like to see us "demote" the update site instructions and promote marketplace on this page. http://www.jboss.org/tools/download.html Granted, the expert user can navigate around ours and others update sites, picking and choosing the specific features they want. Here, I am mostly worried about the person trying out JBoss Tools for the very first time.
          Nick Boldt
          added a comment - - edited

          So instead of:

          • the link to learn more about the Eclipse Marketplace Client (MPC) and
          • the "favorite this @ Eclipse Marketplace"

          you'd rather see a whole section explaining that users should

          • "use Eclipse MPC in your existing Eclipse Helios bundle to install JBoss Tools?"

          Would that go above or below the section on JBDS?

          Maybe I can 'shop these two images together to create a simple click-to-install banner. I guess I'd have to link to http://marketplace.eclipse.org/node/15557 ?


          Show
          Nick Boldt
          added a comment - - edited So instead of: the link to learn more about the Eclipse Marketplace Client (MPC) and the "favorite this @ Eclipse Marketplace" you'd rather see a whole section explaining that users should "use Eclipse MPC in your existing Eclipse Helios bundle to install JBoss Tools?" Would that go above or below the section on JBDS? Maybe I can 'shop these two images together to create a simple click-to-install banner. I guess I'd have to link to http://marketplace.eclipse.org/node/15557 ?
          Max Rydahl Andersen
          added a comment -

          Lets not mix unknown Eclipse Marketplace grey stuff into our page

          Lets just use http://marketplace.eclipse.org/content/jboss-tools-indigo/embed-install-button and http://marketplace.eclipse.org/content/jboss-tools-1/embed-install-button and add as first line under Stable / Development columns.

          On that note I've created https://bugs.eclipse.org/bugs/show_bug.cgi?id=365410 to make that button even simpler.

          Show
          Max Rydahl Andersen
          added a comment - Lets not mix unknown Eclipse Marketplace grey stuff into our page Lets just use http://marketplace.eclipse.org/content/jboss-tools-indigo/embed-install-button and http://marketplace.eclipse.org/content/jboss-tools-1/embed-install-button and add as first line under Stable / Development columns. On that note I've created https://bugs.eclipse.org/bugs/show_bug.cgi?id=365410 to make that button even simpler.
          Max Rydahl Andersen
          added a comment -

          I've commited a site.xml so everything that is in Abridged is actually available from the subparts.

          Show
          Max Rydahl Andersen
          added a comment - I've commited a site.xml so everything that is in Abridged is actually available from the subparts.
          Burr Sutter
          added a comment -

          I like the embed install button trick.

          Show
          Burr Sutter
          added a comment - I like the embed install button trick.
          Nick Boldt
          added a comment -

          OK, how's this new markup?

          https://www.jboss.org/tools/download/

          Show
          Nick Boldt
          added a comment - OK, how's this new markup? https://www.jboss.org/tools/download/
          Max Rydahl Andersen
          added a comment -

          Remove the "or * Favorite" in the columns and im sold.

          Show
          Max Rydahl Andersen
          added a comment - Remove the "or * Favorite" in the columns and im sold.
          Nick Boldt
          added a comment -

          OK, done. https://www.jboss.org/tools/download/

          FWIW, here's what's in JBT Abridged category for M5:


          Show
          Nick Boldt
          added a comment - OK, done. https://www.jboss.org/tools/download/ FWIW, here's what's in JBT Abridged category for M5:
          Burr Sutter
          added a comment -

          Much improved, do we need the big green arrow, it seems to take up lots of space but not really have a main purpose.

          Show
          Burr Sutter
          added a comment - Much improved, do we need the big green arrow, it seems to take up lots of space but not really have a main purpose.
          Max Rydahl Andersen
          added a comment -

          didnt realize the screenshot was actually the real page

          Why do we have to have that dull grey background on the install and favorite button instead of the nice transparent ones provided by eclipse marketplace default ?

          Show
          Max Rydahl Andersen
          added a comment - didnt realize the screenshot was actually the real page Why do we have to have that dull grey background on the install and favorite button instead of the nice transparent ones provided by eclipse marketplace default ?
          Nick Boldt
          added a comment -

          To make it stand out as a call to action / something different than a link.

          Show
          Nick Boldt
          added a comment - To make it stand out as a call to action / something different than a link.
          Lucia Jelinkova
          added a comment -

          Since everybody seems happy with the resolution (last comment was in December) I am closing this Jira.

          Show
          Lucia Jelinkova
          added a comment - Since everybody seems happy with the resolution (last comment was in December) I am closing this Jira.

            People

            • Assignee:
              Max Rydahl Andersen
              Reporter:
              Burr Sutter
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: