Details

    • Type: Task
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: EWS 2.0.0
    • Labels:
      None

      Description

      EWS Release Notes

      1. Section 1.2 JBoss Components
      The component versions are out-of-date.
      Refer to the wiki or search for component update in JIRA.
      http://intranet.corp.redhat.com/ic/intranet/EWS10Engineering.html
      NOTE: mod_cluster version is 1.0.10

      2. Section 1.2 NOTE boxes: We should find out the default versions in RHEL6 and include them

      3. Hibernate API conflict . Section 1.2 says 1.0 API, section 2 says 2.0 API

      4. Chapter2 new with this release : Hibernate should also include Hibernate ANnotations 3.4.0.GA_CP04

      5. Chapter2 new with this release: Should also support for RHEL6. It's the first time we are shipping binaries for rhel6

      6. JBPAPP-6197 Using the Tomcat shutdown procedure /usr/sbin/tomcat6 fails when installed from RPM on RHEL 6.
      This is only when JON is used to manage a tomcat instance installed via rpm's. Starting/Stopping through JBoss ON

      7. JBPAPP-4873 Running tomcat 5 or 6 with security manager enabled fails to start with the default catalina.policy.
      This issue is still being discussed. It might apply only for rpm's now. Please keep a watch.

      8. JBPAPP-3938 The manager application is unable to undeploy a .war application deployed on the Tomcat 5 server. Deploying an expanded .war throws a similar error but does undeploy the application.
      This issue is fixed.

      9. JBPAPP-3755 The current JBoss ON plugin (v2.3) for JBoss Enterprise Web Server is not supported on Windows or Solaris platforms, and there are several known issues on Red Hat Enterprise Linux. JBoss ON support for JBoss Enterprise Web Server on these platforms is planned for a future release of JBoss ON.
      This can be removed. The current version (2.4.1) supports RHEL and Solaris, broken with windows, that issue is already documented.

      10.JBPAPP-3735 The Apache HTTP Server module mod_ssl provides an interface to the OpenSSL library, which provides Strong Encryption using the Transport Layer Security/Secure Sockets Layer security protocols. To use this feature, install the mod_ssl package.
      This should be moved to the installation guide.

      11. JBPAPP-3734 Unless <package>.noarch is specified for Tomcat 5 packages, yum fetches all Tomcat 5 packages from the Red Hat Enterprise Linux 5 base channel instead of the JBoss Enterprise Web Server channel. The installation instructions have been modified to include a work-around for this issue.
      This might not be required. I've asked my team to check about this in the installation guide.

      12. JBPAPP-3646 The Tomcat 6 test suite attempts to compile and execute org.apache.catalina.tomcat.util.http.TestCookies instead of org.apache.tomcat.util.http.TestCookies. This is a problem upstream and is expected to be fixed for the next release of JBoss Enterprise Web Server.
      This might be fixed. Please watch the JIRA for QE comments.

      13. JBPAPP-3644 Setting SECURITY_MANAGER="true" in sysconfig/tomcat5 or sysconfig/tomcat6 has no effect. To start the server securely, users must start with the -security flag,
      This might be fixed. Please watch the JIRA for QE comments.

      14. JBPAPP-6257 belongs to mod_cluster known issues not hibernate
      JBPAPP-3349 might be fixed. Watch JIRA for QE comments.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                permaine Permaine Cheung
                Reporter:
                rrajesh Rajesh Rajasekaran
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: