Uploaded image for project: 'JBoss ESB'
  1. JBoss ESB
  2. JBESB-478

Redeploying the groovy quickstart loop problem

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 4.2 Milestone Release 1
    • Fix Version/s: 4.2 Milestone Release 1
    • Component/s: None
    • Labels:
      None
    • Environment:
      any

      Description

      (Burr says I noticed that if you redeploy the groovy quickstart more than once it goes into some sort of infinite loop on the ESB server console.

        Gliffy Diagrams

          Activity

          tfennelly Tom Fennelly added a comment -

          Attached a stack trace as it appears on the AS during redeploy/shutdown. Would appear as though the AS is going through it's undeploy sequences (undeploying/unbinding queues etc) before the ESB deployer is.

          kconner Kevin Conner added a comment -

          Tom's issue is different from the stacktrace which Kurt added.

          Tom's issue is a consequence of the 'russian doll' nature of the deployment, specifically the fact that sub deployers get stopped before the parent deployer.

          The JNDI entries relating to the queues are therefore removed while they are still being used by the ESB.

          I am investigating possible solutions.

          kconner Kevin Conner added a comment -

          This should have been solved by simply adding dependencies on the message queues. Unfortunately there was a bug in the deployer which meant that previous deployments were never released.

          kconner Kevin Conner added a comment -

          Deployer fix committed into MP1 in revision 10451, head in revision 10452.

          kconner Kevin Conner added a comment -

          The verbosity of this issue was caused by the lack of a backoff in the MessageAwareListener and has been fixed.

          Two problems were identified as potential causes of the courier error, one was dealt with by the contextualising of the courier cleanup and the other was fixed by the specification of dependencies in dependency.xml (plus a deployer fix).

          No more outstanding issues are known.


            People

            • Assignee:
              kconner Kevin Conner
              Reporter:
              kurtstam Kurt Stam
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development