Uploaded image for project: 'JBoss ESB'
  1. JBoss ESB
  2. JBESB-316

Classloader issues on sar redeployment

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 4.0 CR1
    • Fix Version/s: 4.0
    • Component/s: None
    • Labels:
      None

      Description

      Redeployment of the core services causes the following problems

      • LinkageError against XMLSerializer
      • NPEs in AS RepositoryClassLoader

      The causes are the inclusion of the XML/xerces/xalan jars and the failure to unbind the juddi services.

        Gliffy Diagrams

          Activity

          kconner Kevin Conner added a comment -

          Fixed in revision 8658


            People

            • Assignee:
              kconner Kevin Conner
              Reporter:
              kconner Kevin Conner
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development