Uploaded image for project: 'JBoss ESB'
  1. JBoss ESB
  2. JBESB-250

Listeners fail after a lengthy period of being active.

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 4.0
    • Component/s: Rosetta
    • Labels:
      None

      Description

      From Burr:

      "It is really simple, when a service is auto-reloaded via its parameterReloadSecs="10" attribute in the esb-config.xml it sometimes fails to properly go through the self-registration process with the registry. Unfortunately it is not consistent.

      We'll just need to leave a few listeners running some place to see how they behave over time."

      From Kurt:

      "I see this in the logs when it reloads the config (sometimes):

      [JmsQueueListener] Unregistering this EPR done: creditagency
      [java] 14:36:10,880 DEBUG [SocketManager] End ReadTask.run
      [java] 14:36:10,880 DEBUG [UILClientILService] Stopping
      [java] 14:36:10,880 DEBUG [SocketManager] End WriteTask.run
      [java] 14:36:10,927 INFO [JmsQueueListener] Unregistering this EPR done: creditagency
      [java] 14:36:10,942 DEBUG [SocketManager] End ReadTask.run
      [java] 14:36:10,942 DEBUG [UILClientILService] Stopping
      [java] 14:36:10,942 DEBUG [SocketManager] End WriteTask.run
      [java] 14:36:19,348 INFO [JmsQueueListener] Unregistering this EPR, we're going to reload: creditagency

      so it goes to unregister twice.. the second time we get a stacktrace, since it's already gone. Do we have more then 1 JmsQueueListener thread??"

        Gliffy Diagrams

          Issue Links

            Activity

            tfennelly Tom Fennelly added a comment -

            I've been trying to reproduce this and can't - used one of the quickstarts, set the reload time to 10s for both ESB aware and unaware listener configs. Left running for a few hours - no exceptions. Talked with kurt and he says that a fix he out in for yesterday for scout should have fixed this bug - appears as though it has


              People

              • Assignee:
                tfennelly Tom Fennelly
                Reporter:
                marklittle Mark Little
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Development