Uploaded image for project: 'JBeret'
  1. JBeret
  2. JBERET-416

Upgrade jberet-ui to use newer JavaScript framework

    Details

    • Type: Feature Request
    • Status: Open (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 1.3.0.Final
    • Fix Version/s: None
    • Component/s: jberet-ui
    • Labels:
      None

      Description

      See JBeret forum discussion:
      https://developer.jboss.org/thread/277953

      current version of jberet-ui is based on AngularJS (1.4), which is quite old (~5 years old) in ui app world. Need to consider upgrading it to more modern JavaScript framework for better usability, security, performance and extensibility.

      https://reactjs.org/
      https://www.patternfly.org/
      https://github.com/patternfly/patternfly-react

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  cfang Cheng Fang
                  Reporter:
                  cfang Cheng Fang
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated: