JBoss Enterprise Portal Platform
  1. JBoss Enterprise Portal Platform
  2. JBEPP-1195

Log level improvement in FallbackIdentityStoreRepository class (PicketLink IDM)

    Details

    • Type: Enhancement Enhancement
    • Status: Closed (View Workflow)
    • Priority: Major Major
    • Resolution: Migrated to another ITS
    • Affects Version/s: 5.1.0.GA
    • Fix Version/s: 5.2.1.GA
    • Component/s: None
    • Labels:
      None
    • Release Notes Docs Status:
      Not Yet Documented
    • NEEDINFO:
      Nobody
    • Similar Issues:
      Show 10 results 

      Description

      org.picketlink.idm.impl.repository.FallbackIdentityStoreRepository doesn't throw an ERROR exception when a ldap connection has timed out.

      To see that exception user needs to enable the INFO logging to "org.picketlink" category, then it prints the failed connection attempt successfully.

      2011-09-19 11:54:44,315 INFO [org.picketlink.idm.impl.repository.FallbackIdentityStoreRepository] (main) Failed to create IdentityObject:
      org.picketlink.idm.common.exception.IdentityException: Could not obtain LDAP connection:

      Caused by: javax.naming.CommunicationException: [host]:[port] [Root exception is java.net.SocketTimeoutException: connect timed out]

      This enhancement is to change the log level of from INFO to ERROR and to improve the log messages in

      ./picketlink-idm/picketlink-idm-core/src/main/java/org/picketlink/idm/impl/repository/FallbackIdentityStoreRepository.java

      Instead of using INFO it would be easier to see the issue with an ERROR log level.

      Here is an example of log to be improved/changed to ERROR:

      try

      { [source] }

      catch (IdentityException e)
      {
      if (log.isLoggable(Level.INFO))

      { log.log(Level.INFO, "Failed to create IdentityObject: ", e); }

      }

        Gliffy Diagrams

          Activity

          Marek Posolda added a comment -

          I've commited fix into Picketlink IDM trunk - https://source.jboss.org/changelog/PicketLink?cs=1367 . I added SEVERE logging instead of INFO for all exceptions, which are not propagated to the caller. For those, which are propagated there is FINER logging, but it seems to be sufficient since the exception should be processed and logged by the caller.

          btw. I used SEVERE category instead of ERROR, because Picketlink IDM is using JDK logging and it does not support ERROR category (categories are SEVERE, WARN, INFO, FINE, FINER, FINEST)

          Marek Posolda added a comment -

          Only needed action is to release Picketlink IDM and update dependency in EPP pom.xml.

          RH Bugzilla Integration added a comment -

          This issue has been migrated to Bugzilla bug 794129. Please note that this JIRA issue has been closed as part of the migration and therefore you will need to check the Bugzilla issue to find the current status.


            People

            • Assignee:
              Marek Posolda
              Reporter:
              Bruno Machado
            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development