Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Rejected
    • Affects Version/s: 6.1.0.Alpha1
    • Fix Version/s: None
    • Component/s: OSGi
    • Labels:
      None
    • Steps to Reproduce:
      Hide

      Deploy org.eclipse.jetty.servlet:9.0.0.v20130308 or any jetty bundle 9.0+ version..

      Show
      Deploy org.eclipse.jetty.servlet:9.0.0.v20130308 or any jetty bundle 9.0+ version..

      Description

      
      
      13:16:13,163 ERROR [org.jboss.osgi.framework] (MSC service thread 1-6) JBOSGI011023: Cannot start bundle: org.eclipse.jetty.servlet:9.0.0.v20130308: org.osgi.framework.BundleException: JBOSGI011251: Unsupported execution environment [JavaSE-1.7] we have: [OSGi/Minimum-1.1, J2SE-1.1, OSGi/Minimum-1.2, J2SE-1.2, J2SE-1.3, J2SE-1.4, J2SE-1.5, JavaSE-1.6]
      	at org.jboss.osgi.framework.internal.HostBundleState.assertStartConditions(HostBundleState.java:429) [jbosgi-framework-core-2.1.0.CR12.jar:2.1.0.CR12]
      	at org.jboss.osgi.framework.internal.AbstractBundleState.startWithOptions(AbstractBundleState.java:534) [jbosgi-framework-core-2.1.0.CR12.jar:2.1.0.CR12]
      	at org.jboss.osgi.framework.internal.AbstractBundleState.start(AbstractBundleState.java:530) [jbosgi-framework-core-2.1.0.CR12.jar:2.1.0.CR12]
      	at org.jboss.osgi.framework.spi.BootstrapBundlesActivate.start(BootstrapBundlesActivate.java:82) [jbosgi-framework-core-2.1.0.CR12.jar:2.1.0.CR12]
      	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA.jar:1.0.4.GA]
      	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA.jar:1.0.4.GA]
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_13]
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_13]
      	at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_13]
      
      13:16:13,214 ERROR [org.jboss.osgi.framework] (MSC service thread 1-6) JBOSGI011023: Cannot start bundle: org.eclipse.jetty.http:9.0.0.v20130308: org.osgi.framework.BundleException: JBOSGI011251: Unsupported execution environment [JavaSE-1.7] we have: [OSGi/Minimum-1.1, J2SE-1.1, OSGi/Minimum-1.2, J2SE-1.2, J2SE-1.3, J2SE-1.4, J2SE-1.5, JavaSE-1.6]
      	at org.jboss.osgi.framework.internal.HostBundleState.assertStartConditions(HostBundleState.java:429) [jbosgi-framework-core-2.1.0.CR12.jar:2.1.0.CR12]
      	at org.jboss.osgi.framework.internal.AbstractBundleState.startWithOptions(AbstractBundleState.java:534) [jbosgi-framework-core-2.1.0.CR12.jar:2.1.0.CR12]
      	at org.jboss.osgi.framework.internal.AbstractBundleState.start(AbstractBundleState.java:530) [jbosgi-framework-core-2.1.0.CR12.jar:2.1.0.CR12]
      	at org.jboss.osgi.framework.spi.BootstrapBundlesActivate.start(BootstrapBundlesActivate.java:82) [jbosgi-framework-core-2.1.0.CR12.jar:2.1.0.CR12]
      	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA.jar:1.0.4.GA]
      	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA.jar:1.0.4.GA]
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_13]
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_13]
      	at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_13]
      
      13:16:13,216 ERROR [org.jboss.osgi.framework] (MSC service thread 1-6) JBOSGI011023: Cannot start bundle: org.eclipse.jetty.security:9.0.0.v20130308: org.osgi.framework.BundleException: JBOSGI011251: Unsupported execution environment [JavaSE-1.7] we have: [OSGi/Minimum-1.1, J2SE-1.1, OSGi/Minimum-1.2, J2SE-1.2, J2SE-1.3, J2SE-1.4, J2SE-1.5, JavaSE-1.6]
      	at org.jboss.osgi.framework.internal.HostBundleState.assertStartConditions(HostBundleState.java:429) [jbosgi-framework-core-2.1.0.CR12.jar:2.1.0.CR12]
      	at org.jboss.osgi.framework.internal.AbstractBundleState.startWithOptions(AbstractBundleState.java:534) [jbosgi-framework-core-2.1.0.CR12.jar:2.1.0.CR12]
      	at org.jboss.osgi.framework.internal.AbstractBundleState.start(AbstractBundleState.java:530) [jbosgi-framework-core-2.1.0.CR12.jar:2.1.0.CR12]
      	at org.jboss.osgi.framework.spi.BootstrapBundlesActivate.start(BootstrapBundlesActivate.java:82) [jbosgi-framework-core-2.1.0.CR12.jar:2.1.0.CR12]
      	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA.jar:1.0.4.GA]
      	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA.jar:1.0.4.GA]
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_13]
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_13]
      	at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_13]
      
      13:16:13,233 ERROR [org.jboss.osgi.framework] (MSC service thread 1-6) JBOSGI011023: Cannot start bundle: org.eclipse.jetty.jmx:9.0.0.v20130308: org.osgi.framework.BundleException: JBOSGI011251: Unsupported execution environment [JavaSE-1.7] we have: [OSGi/Minimum-1.1, J2SE-1.1, OSGi/Minimum-1.2, J2SE-1.2, J2SE-1.3, J2SE-1.4, J2SE-1.5, JavaSE-1.6]
      	at org.jboss.osgi.framework.internal.HostBundleState.assertStartConditions(HostBundleState.java:429) [jbosgi-framework-core-2.1.0.CR12.jar:2.1.0.CR12]
      	at org.jboss.osgi.framework.internal.AbstractBundleState.startWithOptions(AbstractBundleState.java:534) [jbosgi-framework-core-2.1.0.CR12.jar:2.1.0.CR12]
      	at org.jboss.osgi.framework.internal.AbstractBundleState.start(AbstractBundleState.java:530) [jbosgi-framework-core-2.1.0.CR12.jar:2.1.0.CR12]
      	at org.jboss.osgi.framework.spi.BootstrapBundlesActivate.start(BootstrapBundlesActivate.java:82) [jbosgi-framework-core-2.1.0.CR12.jar:2.1.0.CR12]
      	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA.jar:1.0.4.GA]
      	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA.jar:1.0.4.GA]
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_13]
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_13]
      	at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_13]
      
      13:16:13,235 ERROR [org.jboss.osgi.framework] (MSC service thread 1-6) JBOSGI011023: Cannot start bundle: org.eclipse.jetty.util:9.0.0.v20130308: org.osgi.framework.BundleException: JBOSGI011251: Unsupported execution environment [JavaSE-1.7] we have: [OSGi/Minimum-1.1, J2SE-1.1, OSGi/Minimum-1.2, J2SE-1.2, J2SE-1.3, J2SE-1.4, J2SE-1.5, JavaSE-1.6]
      	at org.jboss.osgi.framework.internal.HostBundleState.assertStartConditions(HostBundleState.java:429) [jbosgi-framework-core-2.1.0.CR12.jar:2.1.0.CR12]
      	at org.jboss.osgi.framework.internal.AbstractBundleState.startWithOptions(AbstractBundleState.java:534) [jbosgi-framework-core-2.1.0.CR12.jar:2.1.0.CR12]
      	at org.jboss.osgi.framework.internal.AbstractBundleState.start(AbstractBundleState.java:530) [jbosgi-framework-core-2.1.0.CR12.jar:2.1.0.CR12]
      	at org.jboss.osgi.framework.spi.BootstrapBundlesActivate.start(BootstrapBundlesActivate.java:82) [jbosgi-framework-core-2.1.0.CR12.jar:2.1.0.CR12]
      	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA.jar:1.0.4.GA]
      	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA.jar:1.0.4.GA]
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_13]
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_13]
      	at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_13]
      
      13:16:13,236 ERROR [org.jboss.osgi.framework] (MSC service thread 1-6) JBOSGI011023: Cannot start bundle: org.eclipse.jetty.server:9.0.0.v20130308: org.osgi.framework.BundleException: JBOSGI011251: Unsupported execution environment [JavaSE-1.7] we have: [OSGi/Minimum-1.1, J2SE-1.1, OSGi/Minimum-1.2, J2SE-1.2, J2SE-1.3, J2SE-1.4, J2SE-1.5, JavaSE-1.6]
      	at org.jboss.osgi.framework.internal.HostBundleState.assertStartConditions(HostBundleState.java:429) [jbosgi-framework-core-2.1.0.CR12.jar:2.1.0.CR12]
      	at org.jboss.osgi.framework.internal.AbstractBundleState.startWithOptions(AbstractBundleState.java:534) [jbosgi-framework-core-2.1.0.CR12.jar:2.1.0.CR12]
      	at org.jboss.osgi.framework.internal.AbstractBundleState.start(AbstractBundleState.java:530) [jbosgi-framework-core-2.1.0.CR12.jar:2.1.0.CR12]
      	at org.jboss.osgi.framework.spi.BootstrapBundlesActivate.start(BootstrapBundlesActivate.java:82) [jbosgi-framework-core-2.1.0.CR12.jar:2.1.0.CR12]
      	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA.jar:1.0.4.GA]
      	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA.jar:1.0.4.GA]
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_13]
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_13]
      	at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_13]
      
      13:16:13,238 ERROR [org.jboss.osgi.framework] (MSC service thread 1-6) JBOSGI011023: Cannot start bundle: org.eclipse.jetty.io:9.0.0.v20130308: org.osgi.framework.BundleException: JBOSGI011251: Unsupported execution environment [JavaSE-1.7] we have: [OSGi/Minimum-1.1, J2SE-1.1, OSGi/Minimum-1.2, J2SE-1.2, J2SE-1.3, J2SE-1.4, J2SE-1.5, JavaSE-1.6]
      	at org.jboss.osgi.framework.internal.HostBundleState.assertStartConditions(HostBundleState.java:429) [jbosgi-framework-core-2.1.0.CR12.jar:2.1.0.CR12]
      	at org.jboss.osgi.framework.internal.AbstractBundleState.startWithOptions(AbstractBundleState.java:534) [jbosgi-framework-core-2.1.0.CR12.jar:2.1.0.CR12]
      	at org.jboss.osgi.framework.internal.AbstractBundleState.start(AbstractBundleState.java:530) [jbosgi-framework-core-2.1.0.CR12.jar:2.1.0.CR12]
      	at org.jboss.osgi.framework.spi.BootstrapBundlesActivate.start(BootstrapBundlesActivate.java:82) [jbosgi-framework-core-2.1.0.CR12.jar:2.1.0.CR12]
      	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA.jar:1.0.4.GA]
      	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA.jar:1.0.4.GA]
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_13]
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_13]
      	at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_13]
      
      

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  thomas.diesler Thomas Diesler
                  Reporter:
                  Aaron.Whiteside Aaron Whiteside
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  5 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: