Details

    • Type: Enhancement
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate Issue
    • Affects Version/s: 6.4.0.GA
    • Fix Version/s: 7.1.0.DR12
    • Component/s: Clustering, REST
    • Labels:
      None

      Description

      JBoss EAP 6.4.7 is still shipping with old jackson libraries in $eap-6.4.7/modules/system/layers/base. EAP includes jackson 2.4.1, but the latest version of jackson is 2.8.0. And the versions are not cross-compatible, meaning an application that relies on a later version of the jackson libraries will throw class compatibility exceptions on startup, unless the libraries are manually updated.

      Please upgrade the com.fasterxml.jackson libraries.

      Or consider removing them from modules altogether. Having them in modules makes it more likely than not that they'll conflict with deployed applications that also rely on jackson.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  asoldano Alessio Soldano
                  Reporter:
                  rhit_lapeters Lance Peterson
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: