Uploaded image for project: 'JBoss Enterprise Application Platform'
  1. JBoss Enterprise Application Platform
  2. JBEAP-3337

Enabling statistics in web console requires reload while it doesn't in CLI

    Details

      Description

      If I want to enable statistics for Web Services subsystem, I do it in CLI:

      [standalone@localhost:9990 /] /subsystem=webservices:write-attribute(name=statistics-enabled, value=true)
      {"outcome" => "success"}
      

      Via web console, I navigate to Configuration->Subsystems->Web Services->View
      I click edit and click checkbox for statistics enabled attribute. Now when I submit the value by clicking Save, dialog appears with reload require information.

      There is no need to require reload just for enabling statistics, by the way statistics are accessible even before reload (Runtime->Subsystems->Webservices and try to get wsdl for the web service for several times).

      Note: if there is no active deployment, reload is not required in web console (correct). To reproduce the issue you must have some active WS deployment

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  soul2zimate Chao Wang
                  Reporter:
                  jbliznak Jan Blizňák
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: