Uploaded image for project: 'Developer Studio (JBoss Developer Studio)'
  1. Developer Studio (JBoss Developer Studio)
  2. JBDS-943

JBDS 3 32-bit Carbon does not run on Mac Snow Leopard (OSX 10.6) with default 64-bit JDK

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Out of Date
    • Affects Version/s: 3.0.0.M4
    • Fix Version/s: 3.0.0.CR2
    • Component/s: build, installer
    • Labels:
      None
    • Environment:
      Mac Snow Leopard
      Macintosh-75:Applications jimtyrrell$ java -version
      java version "1.6.0_15"
      Java(TM) SE Runtime Environment (build 1.6.0_15-b03-219)
      Java HotSpot(TM) 64-Bit Server VM (build 14.1-b02-90, mixed mode)

      Description

      Clicking on JBoss Developer Studio.app results in the attached error.

        Gliffy Diagrams

          Activity

          Hide
          maxandersen Max Rydahl Andersen added a comment -

          18% of 6% is very few ...but sure, if we can have it we will but Apple is not making it easy for us with limited resources to handle random noncompatible binary distributions

          Show
          maxandersen Max Rydahl Andersen added a comment - 18% of 6% is very few ...but sure, if we can have it we will but Apple is not making it easy for us with limited resources to handle random noncompatible binary distributions
          Hide
          maxandersen Max Rydahl Andersen added a comment -

          btw. we got the first jboss tools builds coming up with new mac support: https://jira.jboss.org/jira/browse/JBIDE-4523

          Try that out and let us know

          Show
          maxandersen Max Rydahl Andersen added a comment - btw. we got the first jboss tools builds coming up with new mac support: https://jira.jboss.org/jira/browse/JBIDE-4523 Try that out and let us know
          Hide
          maxandersen Max Rydahl Andersen added a comment -

          We now got builds for 32-bit Cocoa which starts on snow leopard.

          pure 64bit not possible because xulrunner does not yet exist for that platform.

          Show
          maxandersen Max Rydahl Andersen added a comment - We now got builds for 32-bit Cocoa which starts on snow leopard. pure 64bit not possible because xulrunner does not yet exist for that platform.
          Hide
          ironduck Erik Mattheis added a comment -

          For the record, xulrunner compiles cleanly in 64 bit from the Mozilla source trunk. there's still a missing piece of the 64 bit SWT implementation for Cocoa, however.

          <https://bugs.eclipse.org/bugs/show_bug.cgi?id=274197>

          Show
          ironduck Erik Mattheis added a comment - For the record, xulrunner compiles cleanly in 64 bit from the Mozilla source trunk. there's still a missing piece of the 64 bit SWT implementation for Cocoa, however. < https://bugs.eclipse.org/bugs/show_bug.cgi?id=274197 >
          Hide
          nickboldt Nick Boldt added a comment -

          A user in #jbosstools reports that adding this to his eclipse.ini / commandline allows VPE / XulRunner to work on OSX 10.6 64-bit:

          -Dorg.eclipse.swt.browser.XULRunnerPath=/Applications/eclipse/plugins/org.mozilla.xulrunner.cocoa.macosx_1.9.1.2/xulrunner

          Show
          nickboldt Nick Boldt added a comment - A user in #jbosstools reports that adding this to his eclipse.ini / commandline allows VPE / XulRunner to work on OSX 10.6 64-bit: -Dorg.eclipse.swt.browser.XULRunnerPath=/Applications/eclipse/plugins/org.mozilla.xulrunner.cocoa.macosx_1.9.1.2/xulrunner

            People

            • Assignee:
              Unassigned
              Reporter:
              jtyrrell Jim Tyrrell
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development