Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Partially Completed
    • Affects Version/s: 5.0.0.GA
    • Fix Version/s: 5.0.0.GA
    • Component/s: runtime
    • Labels:
    • Environment:
      Windows 7 x64
      JDK 6 update 31 (32 bits)
      JBoss BRMS 5.3.0.GA (Standalone)
      JBoss Developer Studio 5.0.0.GA
    • Affects:
      Interactive Demo/Tutorial

      Description

      When I want to run/debug BRMS Rewards Demo,

      I get this exception into the JBoss Developer Studio Console :

      *Exception occurred executing command line.
      Cannot run program "C:\jre6\bin\javaw.exe" (in directory "C:\p\brms-rewards-demo"): CreateProcess error=206, Nom de fichier ou extension trop long*

        Gliffy Diagrams

          Activity

          dgolovin Denis Golovin added a comment -

          I went trough the demos and it seems works as expected in JBDS aside from several exceptions in eclipse log.
          What exactly do you Run/Debug?

          fuetit a a added a comment -

          eclipse.buildId=unknown
          java.version=1.6.0_33
          java.vendor=Sun Microsystems Inc.
          BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=fr_FR
          Framework arguments: -product com.jboss.jbds.product.product
          Command-line arguments: -data C:\p -os win32 -ws win32 -arch x86 -product com.jboss.jbds.product.product

          Error
          Thu Jun 28 09:38:50 CEST 2012
          Exception occurred executing command line.

          java.io.IOException: Cannot run program "C:\jre6\bin\javaw.exe" (in directory "C:\p\brms-rewards-demo"): CreateProcess error=206, Nom de fichier ou extension trop long
          at java.lang.ProcessBuilder.start(Unknown Source)
          at java.lang.Runtime.exec(Unknown Source)
          at org.eclipse.debug.core.DebugPlugin.exec(DebugPlugin.java:848)
          at org.eclipse.jdt.launching.AbstractVMRunner.exec(AbstractVMRunner.java:73)
          at org.eclipse.jdt.internal.launching.StandardVMRunner.run(StandardVMRunner.java:317)
          at org.eclipse.jdt.launching.JavaLaunchDelegate.launch(JavaLaunchDelegate.java:101)
          at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:854)
          at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:703)
          at org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(DebugUIPlugin.java:937)
          at org.eclipse.debug.internal.ui.DebugUIPlugin$8.run(DebugUIPlugin.java:1141)
          at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
          Caused by: java.io.IOException: CreateProcess error=206, Nom de fichier ou extension trop long
          at java.lang.ProcessImpl.create(Native Method)
          at java.lang.ProcessImpl.<init>(Unknown Source)
          at java.lang.ProcessImpl.start(Unknown Source)
          ... 11 more

          dgolovin Denis Golovin added a comment -

          Do you have mentioned locations? The exception says "File name or extension is too long" which comes from operation system. Does it work when you run it from command line?

          fuetit a a added a comment -

          I find a solution:

          There are many jar files links into "JBoss BRMS 5.3 Librairy" with long path.

          When I move all jar files to the Hard Disk root and I change Eclipse Classpath links to them, Run and Debug passed !

          Thanks Denis

          mmalina Martin Malina added a comment -

          There haven't been any commits connected to this so nothing really to verify. Also, the user seems to be happy with Denis' resolution. Thus closing this issue. Please feel free to reopen if needed.


            People

            • Assignee:
              dgolovin Denis Golovin
              Reporter:
              fuetit a a
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development