XMLWordPrintable

    Details

      Description

      I've managed to get Tycho to build the p2 product using a new pom file [1] (which first regenerates the update site locally THEN builds the products for 4 or the 6 supported platforms (suspect I have to just add more platforms to the parent pom to get win64 and carbon64 in there) and a couple minor tweaks to product/features/com.jboss.jbds/pom.xml file.

      [1] https://svn.jboss.org/repos/devstudio/trunk/product/pom-site-and-product.xml

      However, while building, I get some errors:

      java.io.FileNotFoundException: /home/nboldt/eclipse/workspace-jboss/devstudio_trunk/product/features/com.jboss.jbds/target/products/com.jboss.jbds.all/macosx/JBDevStudio.icns (No such file or directory)
      
      Error - 7 icon(s) not replaced in /tmp/p2.brandingIron9043279577960813921/launcher.exe using /home/nboldt/eclipse/workspace-jboss/devstudio_trunk/product/features/com.jboss.jbds/target/products/com.jboss.jbds.all/jbds.ico
      

      And, the resulting product can't launch (I only tried the lin64 one):

      !ENTRY org.eclipse.osgi 4 0 2012-01-11 13:46:58.598
      !MESSAGE Application error
      !STACK 1
      java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).
              at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:74)
              at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
              at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
              at java.lang.reflect.Method.invoke(Method.java:597)
              at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
              at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
              at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
              at org.eclipse.equinox.launcher.Main.main(Main.java:1386)
      

      Note too the jbdevstudio.ini file is different, the resulting config on disk is different (some IUs missing, some IUs included instead).

      Any idea what's wrong here?

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                dgolovin Denis Golovin
                Reporter:
                nickboldt Nick Boldt
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: