Uploaded image for project: 'Application Server 3  4  5 and 6'
  1. Application Server 3 4 5 and 6
  2. JBAS-9460

[JBOSS6] DuplicateClass when starting JBoss 6.1 with a WAR / EAR containings struts 2 & tiles application

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 6.1.0
    • Fix Version/s: None
    • Component/s: None
    • Environment:

      Windows Vista
      JDK1.6

    • Steps to Reproduce:
      Hide

      Copy the EAR & WAR provided
      start the server
      Try to redeploy the war
      --> the error come

      Show
      Copy the EAR & WAR provided start the server Try to redeploy the war --> the error come

      Description

      Based on the provided attached sample, if I put the war file on my deploy directory, start the server and try to redeploy the war I've got lot of Linkage errors for nearly all the class files used :

      <<
      2011-11-22 20:06:07,850 WARN [org.jboss.detailed.classloader.ClassLoaderManager] (HDScanner) Unexpected error during load of:org.apache.commons.digester.RegexMatcher: java.lang.LinkageError: loader (instance of org/jboss/classloader/spi/base/BaseClassLoader): attempted duplicate class definition for name: "org/apache/commons/digester/RegexMatcher"
      at java.lang.ClassLoader.defineClass1(Native Method) [:1.6.0_21]
      at java.lang.ClassLoader.defineClassCond(ClassLoader.java:632) [:1.6.0_21]
      at java.lang.ClassLoader.defineClass(ClassLoader.java:616) [:1.6.0_21]
      at org.jboss.classloader.spi.base.BaseClassLoader.access$200(BaseClassLoader.java:52) [jboss-classloader.jar:2.2.1.GA]
      at org.jboss.classloader.spi.base.BaseClassLoader$2.run(BaseClassLoader.java:650) [jboss-classloader.jar:2.2.1.GA]
      at org.jboss.classloader.spi.base.BaseClassLoader$2.run(BaseClassLoader.java:609) [jboss-classloader.jar:2.2.1.GA]
      at java.security.AccessController.doPrivileged(Native Method) [:1.6.0_21]
      ..
      >>

      If I start JBoss without the war and then try to deploy it many time it doesn't fail, however as soon that the server start with the war, the linkage errors come.

      Is it a bug or a misconfiguration of my war ?

      Regards,
      Blured.

        Gliffy Diagrams

          Attachments

          1. poc_jboss_ear.ear
            2 kB
          2. poc_jboss_web.war
            3.76 MB
          3. server.log
            1.48 MB

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                blured75 blured blured
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated: