Uploaded image for project: 'Application Server 3  4  5 and 6'
  1. Application Server 3 4 5 and 6
  2. JBAS-8319

[Regression in JBoss 5.x and 6.x compared to 4.x] VFS doesn't support fetching http resources

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: JBossAS-5.0.1.GA, JBossAS-5.1.0.GA, 6.0.0.M4, 6.0.0.M5
    • Fix Version/s: 6.0.0.CR1
    • Component/s: ProfileService
    • Environment:

      Bug has been observed on all three versions:

      • JBoss 5.0.1 GA (jboss-vfs 2.1.2 GA)
      • JBoss 5.1.0 GA (jboss-vfs 2.1.0 GA)
      • JBoss 6.0.0 M4 (jboss-vfs 3.0.0 CR5)

      Description

      I'm currently working on the porting of our JBoss 4.2 infrastructure to JBoss 5.x, and even maybe 6.x.

      Since JBoss doesn't allow automated remote deployment (i.e., via JMX for example -a manual access to the JBoss console is necessary) of applications (WAR, EJBs, EARs, etc.), we used to call the JBoss MainDeployer's deploy method with a URL pointing to an HTTP URL which contains all our deployable artifacts.

      As of JBoss 5.x, this broke. I'm attaching stack traces for JBoss 5.1.0 and JBoss 6.0.0 M3:

      • In JBoss 5 we clearly see that org.jboss.virtual.VFS.getVFS throws: java.io.IOException: No context factory for http://192.168.0.12:58407/simple-war-1.0.3-SNAPSHOT.war
      • In JBoss 6 the exception is even more interesting: Invalid or unreadable WAR file : /simple-war-1.0.3-SNAPSHOT.war

        Gliffy Diagrams

        1. stacktrace-jboss-5.txt
          7 kB
          Savas Ali Tokmen
        2. stacktrace-jboss-6.txt
          10 kB
          Savas Ali Tokmen
        3. stacktrace-jboss6-m5.txt
          30 kB
          Savas Ali Tokmen

          Issue Links

            Activity

            alesj Ales Justin added a comment -

            Ah, OK, we established that this is not a VFS issue.
            Nor is deployers, since deployers only understand what VFS tells them to do.
            Potentially there could be "remote" impl of Deployment,
            but my guess is, like I already mentioned, that this should be handled by PS.

            shelly.mcgowan Shelly McGowan added a comment -

            Emanuel, is there work planned for CR1 ?

            emuckenhuber Emanuel Muckenhuber added a comment -

            This should be working in CR1. However MainDeployer is a deprecated service, which is going to be removed in the next major release of AS.

            alitokmen Savas Ali Tokmen added a comment -

            The fix has been verified opn JBoss AS 6.0.0 CR1.

            Thank you for your continuing efforts.

            ozizka Ondrej Zizka added a comment -

            Will this be backported to AS/EAP 5?


              People

              • Assignee:
                emuckenhuber Emanuel Muckenhuber
                Reporter:
                alitokmen Savas Ali Tokmen
              • Votes:
                2 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Development