Uploaded image for project: 'Application Server 3  4  5 and 6'
  1. Application Server 3 4 5 and 6
  2. JBAS-7246 Track JBoss 6.0.0.M1 testsuite fixes/issues
  3. JBAS-7384

org.jboss.test.webservice.endpoint.EndpointTestCase fails because of beanvalidation deployer

    Details

    • Type: Sub-task
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 6.0.0.M1
    • Component/s: Web Services
    • Labels:
      None
    • Similar Issues:
      Show 10 results 

      Description

      These newly added tests are failing. Filing to track.
      testWSDLAccess:
      javax.wsdl.WSDLException: WSDLException: faultCode=OTHER_ERROR: Unable to resolve imported document at 'http://localhost:8080/jaxws-endpoint?wsdl'.: java.io.FileNotFoundException: This file was not found: http://localhost:8080/jaxws-endpoint?wsdl

      testClientAccess:
      javax.xml.ws.WebServiceException: java.io.IOException: Could not transmit message
      Caused by: org.jboss.ws.WSException: Invalid HTTP server response [404] - Not Found

      testServletAccess:
      java.io.IOException: Server returned HTTP response code: 500 for URL: http://localhost:8080/jaxws-endpoint-servlet?param=hello-world

        Gliffy Diagrams

          Issue Links

            Activity

            ropalka Richard Opalka added a comment -

            21:35:21,741 INFO [MainDeployer] deploy, url=file:/home/opalka/svn/jbossws/stack/native/trunk/modules/testsuite/native-tests/target/test-libs/jaxws-endpoint-servlet.war
            21:35:22,050 INFO [TomcatDeployment] deploy, ctxPath=/jaxws-endpoint-servlet
            21:35:22,288 ERROR [AbstractKernelController] Error installing to PreReal: name=http://jaxws-endpoint-api/jaxws-endpoint state=PostClassLoader mode=Manual requiredState=PreReal
            org.jboss.deployers.spi.DeploymentException: Cannot bind validator factory.
            at org.jboss.deployers.spi.DeploymentException.rethrowAsDeploymentException(DeploymentException.java:49)
            at org.jboss.beanvalidation.deployers.ValidatorFactoryJndiBinderDeployer.deploy(ValidatorFactoryJndiBinderDeployer.java:65)
            at org.jboss.beanvalidation.deployers.ValidatorFactoryJndiBinderDeployer.deploy(ValidatorFactoryJndiBinderDeployer.java:39)
            at org.jboss.deployers.spi.deployer.helpers.AbstractSimpleRealDeployer.internalDeploy(AbstractSimpleRealDeployer.java:62)
            at org.jboss.deployers.spi.deployer.helpers.AbstractRealDeployer.deploy(AbstractRealDeployer.java:50)
            at org.jboss.deployers.plugins.deployers.DeployerWrapper.deploy(DeployerWrapper.java:171)
            at org.jboss.deployers.plugins.deployers.DeployersImpl.doDeploy(DeployersImpl.java:1440)
            at org.jboss.deployers.plugins.deployers.DeployersImpl.doInstallParentFirst(DeployersImpl.java:1158)
            at org.jboss.deployers.plugins.deployers.DeployersImpl.install(DeployersImpl.java:1099)
            at org.jboss.dependency.plugins.AbstractControllerContext.install(AbstractControllerContext.java:348)
            at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:1633)
            at org.jboss.dependency.plugins.AbstractController.incrementState(AbstractController.java:935)
            at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:1083)
            at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:985)
            at org.jboss.dependency.plugins.AbstractController.change(AbstractController.java:823)
            at org.jboss.dependency.plugins.AbstractController.change(AbstractController.java:553)
            at org.jboss.deployers.plugins.deployers.DeployersImpl.process(DeployersImpl.java:782)
            at org.jboss.deployers.plugins.main.MainDeployerImpl.deploy(MainDeployerImpl.java:552)
            at org.jboss.webservices.integration.endpoint.EndpointAPIHttpServer.publish(EndpointAPIHttpServer.java:121)
            at org.jboss.ws.core.jaxws.spi.EndpointImpl.publish(EndpointImpl.java:167)
            at org.jboss.ws.core.jaxws.spi.EndpointImpl.publish(EndpointImpl.java:135)
            at org.jboss.test.ws.jaxws.endpoint.EndpointServlet.init(EndpointServlet.java:64)
            at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1048)
            at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:950)
            at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:4122)
            at org.apache.catalina.core.StandardContext.start(StandardContext.java:4417)
            at org.jboss.web.tomcat.service.deployers.TomcatDeployment.performDeployInternal(TomcatDeployment.java:333)
            at org.jboss.web.tomcat.service.deployers.TomcatDeployment.performDeploy(TomcatDeployment.java:150)
            at org.jboss.web.deployers.AbstractWarDeployment.start(AbstractWarDeployment.java:462)
            at org.jboss.web.deployers.WebModule.startModule(WebModule.java:118)
            at org.jboss.web.deployers.WebModule.start(WebModule.java:97)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:597)
            at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:157)
            at org.jboss.mx.server.Invocation.dispatch(Invocation.java:96)
            at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
            at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
            at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:668)
            at org.jboss.system.microcontainer.ServiceProxy.invoke(ServiceProxy.java:207)
            at $Proxy38.start(Unknown Source)
            at org.jboss.system.microcontainer.StartStopLifecycleAction.installAction(StartStopLifecycleAction.java:42)
            at org.jboss.system.microcontainer.StartStopLifecycleAction.installAction(StartStopLifecycleAction.java:37)
            at org.jboss.dependency.plugins.action.SimpleControllerContextAction.simpleInstallAction(SimpleControllerContextAction.java:62)
            at org.jboss.dependency.plugins.action.AccessControllerContextAction.install(AccessControllerContextAction.java:71)
            at org.jboss.dependency.plugins.AbstractControllerContextActions.install(AbstractControllerContextActions.java:51)
            at org.jboss.dependency.plugins.AbstractControllerContext.install(AbstractControllerContext.java:348)
            at org.jboss.system.microcontainer.ServiceControllerContext.install(ServiceControllerContext.java:298)
            at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:1633)
            at org.jboss.dependency.plugins.AbstractController.incrementState(AbstractController.java:935)
            at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:1083)
            at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:985)
            at org.jboss.dependency.plugins.AbstractController.change(AbstractController.java:823)
            at org.jboss.dependency.plugins.AbstractController.change(AbstractController.java:553)
            at org.jboss.system.ServiceController.doChange(ServiceController.java:689)
            at org.jboss.system.ServiceController.start(ServiceController.java:461)
            at org.jboss.system.deployers.ServiceDeployer.start(ServiceDeployer.java:163)
            at org.jboss.system.deployers.ServiceDeployer.deploy(ServiceDeployer.java:99)
            at org.jboss.system.deployers.ServiceDeployer.deploy(ServiceDeployer.java:46)
            at org.jboss.deployers.spi.deployer.helpers.AbstractSimpleRealDeployer.internalDeploy(AbstractSimpleRealDeployer.java:62)
            at org.jboss.deployers.spi.deployer.helpers.AbstractRealDeployer.deploy(AbstractRealDeployer.java:50)
            at org.jboss.deployers.plugins.deployers.DeployerWrapper.deploy(DeployerWrapper.java:171)
            at org.jboss.deployers.plugins.deployers.DeployersImpl.doDeploy(DeployersImpl.java:1440)
            at org.jboss.deployers.plugins.deployers.DeployersImpl.doInstallParentFirst(DeployersImpl.java:1158)
            at org.jboss.deployers.plugins.deployers.DeployersImpl.doInstallParentFirst(DeployersImpl.java:1179)
            at org.jboss.deployers.plugins.deployers.DeployersImpl.install(DeployersImpl.java:1099)
            at org.jboss.dependency.plugins.AbstractControllerContext.install(AbstractControllerContext.java:348)
            at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:1633)
            at org.jboss.dependency.plugins.AbstractController.incrementState(AbstractController.java:935)
            at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:1083)
            at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:985)
            at org.jboss.dependency.plugins.AbstractController.change(AbstractController.java:823)
            at org.jboss.dependency.plugins.AbstractController.change(AbstractController.java:553)
            at org.jboss.deployers.plugins.deployers.DeployersImpl.process(DeployersImpl.java:782)
            at org.jboss.deployers.plugins.main.MainDeployerImpl.process(MainDeployerImpl.java:702)
            at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:831)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:597)
            at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:157)
            at org.jboss.mx.server.Invocation.dispatch(Invocation.java:96)
            at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
            at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
            at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:668)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:597)
            at org.jboss.jmx.connector.invoker.InvokerAdaptorService.invoke(InvokerAdaptorService.java:266)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:597)
            at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:157)
            at org.jboss.mx.server.Invocation.dispatch(Invocation.java:96)
            at org.jboss.mx.interceptor.AbstractInterceptor.invoke(AbstractInterceptor.java:138)
            at org.jboss.mx.server.Invocation.invoke(Invocation.java:90)
            at org.jboss.mx.interceptor.ModelMBeanOperationInterceptor.invoke(ModelMBeanOperationInterceptor.java:140)
            at org.jboss.jmx.connector.invoker.SerializableInterceptor.invoke(SerializableInterceptor.java:74)
            at org.jboss.mx.server.Invocation.invoke(Invocation.java:90)
            at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
            at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:668)
            at org.jboss.invocation.jrmp.server.JRMPProxyFactory.invoke(JRMPProxyFactory.java:180)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:597)
            at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:157)
            at org.jboss.mx.server.Invocation.dispatch(Invocation.java:96)
            at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
            at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
            at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:668)
            at org.jboss.invocation.jrmp.server.JRMPInvoker$MBeanServerAction.invoke(JRMPInvoker.java:855)
            at org.jboss.invocation.jrmp.server.JRMPInvoker.invoke(JRMPInvoker.java:422)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:597)
            at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:305)
            at sun.rmi.transport.Transport$1.run(Transport.java:159)
            at java.security.AccessController.doPrivileged(Native Method)
            at sun.rmi.transport.Transport.serviceCall(Transport.java:155)
            at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:535)
            at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run0(TCPTransport.java:790)
            at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:649)
            at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
            at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
            at java.lang.Thread.run(Thread.java:619)
            Caused by: javax.naming.NameNotFoundException: http: not bound
            at org.jnp.server.NamingServer.getBinding(NamingServer.java:771)
            at org.jnp.server.NamingServer.getBinding(NamingServer.java:779)
            at org.jnp.server.NamingServer.getObject(NamingServer.java:785)
            at org.jnp.server.NamingServer.rebind(NamingServer.java:244)
            at org.jnp.server.NamingServer.rebind(NamingServer.java:247)
            at org.jnp.interfaces.NamingContext.rebind(NamingContext.java:575)
            at org.jnp.interfaces.NamingContext.rebind(NamingContext.java:540)
            at org.jboss.util.naming.NonSerializableFactory.rebind(NonSerializableFactory.java:185)
            at org.jboss.beanvalidation.util.DefaultJndiBinder.bind(DefaultJndiBinder.java:102)
            at org.jboss.beanvalidation.deployers.ValidatorFactoryJndiBinderDeployer.deploy(ValidatorFactoryJndiBinderDeployer.java:61)
            ... 128 more

            ropalka Richard Opalka added a comment -

            Hi Ales,

            please investigate how to properly fix this issue.

            I'm assigning this issue to you as I see you're the co-author
            of org.jboss.beanvalidation.deployers.*
            I had a look to these deployers code and can't see the workaround
            how to disable this deployer for our usecase.

            Detailed info to help you dig into problem faster:
            We're creating FAKE deployment in
            org.jboss.webservices.integration.endpoint.EndpointAPIHttpServer.publish(final HttpContext context, final Endpoint endpoint)
            and passing it to injected main deployer.

            This usecase have to work (because of the JAX-WS spec.
            requirement to dynamically create WebService endpoints from
            web deployments).

            PS: It works in AS trunk, AS 5.1.0.GA and AS 5.0.1.

            ropalka Richard Opalka added a comment -

            Reassigning to Ales

            ropalka Richard Opalka added a comment -

            To reproduce the problem execute:

            ./build.sh one-test -Dtest=org.jboss.test.webservice.endpoint.EndpointTestCase

            in directory Branch_5_x/testsuite

            alesj Ales Justin added a comment -

            What does beanvalidation deployer do to make this fail?

            ropalka Richard Opalka added a comment -

            Stack trace copied/pasted above should be self explanatory.
            If not please ask beanvalidation developers what'sgoing wrong there.

            ropalka Richard Opalka added a comment -

            Reassigning to Stan (he's repsonsible for BV code)

            ssilvert Stan Silvert added a comment -

            The ValidatorFactoryJndiBinderDeployer is no longer used. The test still fails, but not because of that deployer.


              People

              • Assignee:
                ssilvert Stan Silvert
                Reporter:
                shelly.mcgowan Shelly McGowan
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Development