Uploaded image for project: 'Application Server 3  4  5 and 6'
  1. Application Server 3 4 5 and 6
  2. JBAS-7313

jdbc2 pm: table view collisions between beans from different jars in the same tx

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: No Release
    • Fix Version/s: 6.0.0.M1
    • Component/s: CMP service
    • Labels:
      None
    • Similar Issues:
      Show 10 results 

      Description

      This bug was introduced by JBAS-7238. The problem is "views" object, which is created one per EJB JAR for every transaction, is stored in GlobalTxSynchronization under the same key for all the EJBs no matter from which JAR they are. This results in collisions in case EJBs from different JARs are involved in the same transaction, i.e. views from for one JAR might overwrite the views from another JAR.

        Gliffy Diagrams

          Issue Links

            Activity

            aloubyansky Alexey Loubyansky added a comment -

            Fixed in 5.2.0.Beta1


              People

              • Assignee:
                aloubyansky Alexey Loubyansky
                Reporter:
                aloubyansky Alexey Loubyansky
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Development