Uploaded image for project: 'Application Server 3  4  5 and 6'
  1. Application Server 3 4 5 and 6
  2. JBAS-7096

SLSB with dependency on HASingletonDeployer / Barrier results in error message on second node on startup

    Details

      Description

      Basic cluster, two JBoss 5.1.0 nodes, "all" configuration. First node starts fine. Second node starts, however at the end of starting, any SLSBs that depend on the barrier result in an error being logged at startup (on the second node).

      Example:
      DEPLOYMENTS MISSING DEPENDENCIES:
      Deployment "jboss.j2ee:ear=app-ear.ear,jar=app-ejb.jar,name=BoardPollerMDB,service=EJB3" is missing the following dependencies:
      Dependency "<UNKNOWN jboss.j2ee:ear=app-ear.ear,jar=app-ejb.jar,name=BoardPollerMDB,service=EJB3>" (should be in state "Described", bu
      t is actually in state "** UNRESOLVED Demands 'jboss.ha:service=HASingletonDeployer,type=Barrier' **")

      DEPLOYMENTS IN ERROR:
      Deployment "<UNKNOWN jboss.j2ee:ear=app-ear.ear,jar=app-ejb.jar,name=BoardPollerMDB,service=EJB3>" is in error due to the following reas
      on(s): ** UNRESOLVED Demands 'jboss.ha:service=HASingletonDeployer,type=Barrier' **

      The SLSBs on node 2 do properly start in a failover scenario when node 1 goes down. So functionally things seem OK. However the error message is a little concerning and it leaves us wondering if there is more to the problem.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  smarlow Scott Marlow
                  Reporter:
                  RichardTaylor Richard Taylor
                • Votes:
                  1 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: