Uploaded image for project: 'Application Server 3  4  5 and 6'
  1. Application Server 3 4 5 and 6
  2. JBAS-6934

Tests in org.jboss.test.cluster failing with IBM JDK 1.5 - Failed to start cluster/http/jboss-web-test-service.xml

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: JBossAS-5.1.0.CR1
    • Fix Version/s: 6.0.0.M1
    • Component/s: Test Suite
    • Labels:
      None
    • Environment:
      IBM JDK 1.5
    • Similar Issues:
      Show 10 results 

      Description

      Some clustered tests are failing with this error message:

      Failed to start cluster/http/jboss-web-test-service.xml
      org.jboss.cache.pojo.PojoCacheException: Failed to start cluster/http/jboss-web-test-service.xml
      at org.jboss.cache.pojo.impl.PojoCacheImpl.<init>(PojoCacheImpl.java:63)
      at org.jboss.cache.pojo.PojoCacheFactory.createCache(PojoCacheFactory.java:42)
      at org.jboss.test.cluster.testutil.SessionTestUtil.getConfiguration(SessionTestUtil.java:147)
      at org.jboss.test.cluster.testutil.SessionTestUtil.createCache(SessionTestUtil.java:136)
      at org.jboss.test.cluster.testutil.CacheConfigTestSetup.setUp(CacheConfigTestSetup.java:84)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:20)
      at junit.extensions.TestSetup.run(TestSetup.java:25)
      Caused by: org.jboss.cache.config.ConfigurationException: Unable to build interceptor chain
      at org.jboss.cache.factories.InterceptorChainFactory.construct(InterceptorChainFactory.java:229)
      at org.jboss.cache.factories.ComponentRegistry.getOrCreateComponent(ComponentRegistry.java:318)
      at org.jboss.cache.factories.ComponentRegistry.invokeInjectionMethod(ComponentRegistry.java:279)
      at org.jboss.cache.factories.ComponentRegistry$Component.injectDependencies(ComponentRegistry.java:981)
      at org.jboss.cache.factories.ComponentRegistry.registerComponent(ComponentRegistry.java:255)
      at org.jboss.cache.factories.ComponentRegistry.getOrCreateComponent(ComponentRegistry.java:325)
      at org.jboss.cache.factories.ComponentRegistry.invokeInjectionMethod(ComponentRegistry.java:279)
      at org.jboss.cache.factories.ComponentRegistry$Component.injectDependencies(ComponentRegistry.java:981)
      at org.jboss.cache.factories.ComponentRegistry.registerComponent(ComponentRegistry.java:255)
      at org.jboss.cache.factories.ComponentRegistry.getOrCreateComponent(ComponentRegistry.java:325)
      at org.jboss.cache.factories.ComponentRegistry.invokeInjectionMethod(ComponentRegistry.java:279)
      at org.jboss.cache.factories.ComponentRegistry$Component.injectDependencies(ComponentRegistry.java:981)
      at org.jboss.cache.factories.ComponentRegistry.registerComponent(ComponentRegistry.java:255)
      at org.jboss.cache.factories.ComponentRegistry.getOrCreateComponent(ComponentRegistry.java:325)
      at org.jboss.cache.factories.ComponentRegistry.invokeInjectionMethod(ComponentRegistry.java:279)
      at org.jboss.cache.factories.ComponentRegistry$Component.injectDependencies(ComponentRegistry.java:981)
      at org.jboss.cache.factories.ComponentRegistry.registerComponent(ComponentRegistry.java:255)
      at org.jboss.cache.factories.ComponentRegistry.getOrCreateComponent(ComponentRegistry.java:325)
      at org.jboss.cache.factories.ComponentRegistry.invokeInjectionMethod(ComponentRegistry.java:279)
      at org.jboss.cache.factories.ComponentRegistry$Component.injectDependencies(ComponentRegistry.java:981)
      at org.jboss.cache.factories.ComponentRegistry.registerComponent(ComponentRegistry.java:255)
      at org.jboss.cache.DefaultCacheFactory.bootstrap(DefaultCacheFactory.java:155)
      at org.jboss.cache.DefaultCacheFactory.createAndWire(DefaultCacheFactory.java:141)
      at org.jboss.cache.DefaultCacheFactory.createCache(DefaultCacheFactory.java:120)
      at org.jboss.cache.DefaultCacheFactory.createCache(DefaultCacheFactory.java:93)
      at org.jboss.cache.pojo.impl.PojoCacheImpl.<init>(PojoCacheImpl.java:58)
      Caused by: java.lang.TypeNotPresentException: Type net.jcip.annotations.ThreadSafe not present
      at com.ibm.oti.reflect.AnnotationHelper.getAnnotation(AnnotationHelper.java:38)
      at com.ibm.oti.reflect.AnnotationHelper.getDeclaredAnnotations(AnnotationHelper.java:50)
      at java.lang.Class.getDeclaredAnnotations(Class.java:1620)
      at java.lang.Class.getAnnotations(Class.java:1581)
      at java.lang.Class.getAnnotation(Class.java:1561)
      at java.lang.Class.isAnnotationPresent(Class.java:1648)
      at org.jboss.cache.factories.ComponentRegistry.registerComponent(ComponentRegistry.java:252)
      at org.jboss.cache.factories.ComponentRegistry.getOrCreateComponent(ComponentRegistry.java:325)
      at org.jboss.cache.factories.ComponentRegistry.invokeInjectionMethod(ComponentRegistry.java:279)
      at org.jboss.cache.factories.ComponentRegistry$Component.injectDependencies(ComponentRegistry.java:981)
      at org.jboss.cache.factories.ComponentRegistry.registerComponent(ComponentRegistry.java:255)
      at org.jboss.cache.factories.ComponentRegistry.getOrCreateComponent(ComponentRegistry.java:325)
      at org.jboss.cache.factories.ComponentRegistry.invokeInjectionMethod(ComponentRegistry.java:279)
      at org.jboss.cache.factories.ComponentRegistry$Component.injectDependencies(ComponentRegistry.java:981)
      at org.jboss.cache.factories.ComponentRegistry.registerComponent(ComponentRegistry.java:255)
      at org.jboss.cache.factories.ComponentRegistry.getOrCreateComponent(ComponentRegistry.java:325)
      at org.jboss.cache.factories.ComponentRegistry.invokeInjectionMethod(ComponentRegistry.java:279)
      at org.jboss.cache.factories.ComponentRegistry$Component.injectDependencies(ComponentRegistry.java:981)
      at org.jboss.cache.factories.ComponentRegistry.registerComponent(ComponentRegistry.java:255)
      at org.jboss.cache.factories.ComponentRegistry.getOrCreateComponent(ComponentRegistry.java:325)
      at org.jboss.cache.factories.ComponentRegistry.invokeInjectionMethod(ComponentRegistry.java:279)
      at org.jboss.cache.factories.ComponentRegistry$Component.injectDependencies(ComponentRegistry.java:981)
      at org.jboss.cache.factories.ComponentRegistry.registerComponent(ComponentRegistry.java:255)
      at org.jboss.cache.factories.ComponentRegistry.getOrCreateComponent(ComponentRegistry.java:325)
      at org.jboss.cache.factories.ComponentRegistry.invokeInjectionMethod(ComponentRegistry.java:279)
      at org.jboss.cache.factories.ComponentRegistry$Component.injectDependencies(ComponentRegistry.java:981)
      at org.jboss.cache.factories.ComponentRegistry.registerComponent(ComponentRegistry.java:255)
      at org.jboss.cache.factories.ComponentRegistry.getOrCreateComponent(ComponentRegistry.java:325)
      at org.jboss.cache.factories.ComponentRegistry.invokeInjectionMethod(ComponentRegistry.java:279)
      at org.jboss.cache.factories.ComponentRegistry$Component.injectDependencies(ComponentRegistry.java:981)
      at org.jboss.cache.factories.ComponentRegistry.registerComponent(ComponentRegistry.java:255)
      at org.jboss.cache.factories.InterceptorChainFactory.createInterceptor(InterceptorChainFactory.java:60)
      at org.jboss.cache.factories.InterceptorChainFactory.buildInterceptorChain(InterceptorChainFactory.java:75)
      at org.jboss.cache.factories.InterceptorChainFactory.construct(InterceptorChainFactory.java:225)
      Caused by: java.lang.ClassNotFoundException: net.jcip.annotations.ThreadSafe
      at java.lang.Class.forName(Class.java:163)
      at com.ibm.oti.reflect.AnnotationHelper.getAnnotation(AnnotationHelper.java:33)

      This is the list of the tests failing because of this:
      org.jboss.test.cluster.defaultcfg.simpleweb.test.AttributeBasedMaxUnreplicatedIntervalTestCase
      org.jboss.test.cluster.defaultcfg.simpleweb.test.BuddyReplicationFailoverUnitTestCase
      org.jboss.test.cluster.defaultcfg.simpleweb.test.BuddyReplicationToPassivatedSessionUnitTestCase
      org.jboss.test.cluster.defaultcfg.simpleweb.test.ClusteredSessionNotificationPolicyTestCase
      org.jboss.test.cluster.defaultcfg.simpleweb.test.FieldBasedMaxUnreplicatedIntervalTestCase
      org.jboss.test.cluster.defaultcfg.simpleweb.test.JBossCacheManagerConfigurationUnitTestCase
      org.jboss.test.cluster.defaultcfg.simpleweb.test.ReplicationToPassivatedSessionUnitTestCase
      org.jboss.test.cluster.defaultcfg.simpleweb.test.SessionBasedMaxUnreplicatedIntervalTestCase
      org.jboss.test.cluster.defaultcfg.simpleweb.test.SessionCountUnitTestCase
      org.jboss.test.cluster.defaultcfg.simpleweb.test.SessionExpirationUnitTestCase

      In total it causes 29 failures.

        Gliffy Diagrams

          Issue Links

            Activity

            mmalina Martin Malina added a comment -

            Missing net.jcip.annotations.ThreadSafe was discussed in JBAS-6428. In that case adding jcip-annotations.jar to server/all/lib fixed the problem. Now it seems we need it in the testsuite classpath, too.

            mmalina Martin Malina added a comment -

            Adding the jcip-annotations.jar to classpath (using export CLASSPATH=...) before running the tests fixed the problem. Now how to do it properly?

            rrajesh Rajesh Rajasekaran added a comment -

            Since it's already in the server/lib adding it to the testsuite classpath shouldn't be a problem.

            mmalina Martin Malina added a comment -

            One more testcase, where this is causing failures (6):

            org.jboss.test.cluster.defaultcfg.simpleweb.test.TreeCacheSSOClusterManagerUnitTestCase

            Unable to build interceptor chain
            org.jboss.cache.config.ConfigurationException: Unable to build interceptor chain
            at org.jboss.cache.factories.InterceptorChainFactory.construct(InterceptorChainFactory.java:229)
            at org.jboss.cache.factories.ComponentRegistry.getOrCreateComponent(ComponentRegistry.java:318)
            at org.jboss.cache.factories.ComponentRegistry.invokeInjectionMethod(ComponentRegistry.java:279)
            at org.jboss.cache.factories.ComponentRegistry$Component.injectDependencies(ComponentRegistry.java:981)
            at org.jboss.cache.factories.ComponentRegistry.registerComponent(ComponentRegistry.java:255)
            at org.jboss.cache.DefaultCacheFactory.bootstrap(DefaultCacheFactory.java:155)
            at org.jboss.cache.DefaultCacheFactory.createAndWire(DefaultCacheFactory.java:141)
            at org.jboss.cache.DefaultCacheFactory.createCache(DefaultCacheFactory.java:120)
            at org.jboss.cache.jmx.CacheJmxWrapper.constructCache(CacheJmxWrapper.java:960)
            at org.jboss.cache.jmx.CacheJmxWrapper.create(CacheJmxWrapper.java:613)
            at org.jboss.test.cluster.defaultcfg.simpleweb.test.TreeCacheSSOClusterManagerUnitTestCase.testCacheJmxIntegration(TreeCacheSSOClusterManagerUnitTestCase.java:144)
            Caused by: java.lang.TypeNotPresentException: Type net.jcip.annotations.ThreadSafe not present
            ...

            mmalina Martin Malina added a comment -

            And these, too:
            org.jboss.test.cluster.defaultcfg.test.CacheManagerUnitTestCase (4 failures)
            org.jboss.test.cluster.defaultcfg.test.DRMTestCase (1 failure)

            shelly.mcgowan Shelly McGowan added a comment -

            Added <path refid="net.jcip.classpath"/> to library.classpath in JBPAPP_5_0 branch, rev 90479. Will resolve once committed to trunk.


              People

              • Assignee:
                shelly.mcgowan Shelly McGowan
                Reporter:
                mmalina Martin Malina
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Development