Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: JBossAS-5.1.0.CR1
    • Fix Version/s: 6.0.0.M1
    • Component/s: Test Suite
    • Labels:
      None
    • Environment:

      IBM JDK 1.5

      Description

      Tests in the tests-aop-scoped target of JBoss AS testsuite are failing.
      The tests are:
      org.jboss.test.aop.test.ScopedAnnotatedTestCase
      org.jboss.test.aop.test.ScopedAttachUnitTestCase
      org.jboss.test.aop.test.ScopedEarWithClassesInWebInfTestCase
      org.jboss.test.aop.test.ScopedExtenderBaseLoadedScopedNoParentDelegationTestCase
      org.jboss.test.aop.test.ScopedExtenderBaseLoadedScopedParentDelegationTestCase
      org.jboss.test.aop.test.ScopedExtenderBaseNotLoadedScopedNoParentDelegationTestCase
      org.jboss.test.aop.test.ScopedExtenderBaseNotLoadedScopedParentDelegationTestCase
      org.jboss.test.aop.test.ScopedUnitTestCase
      org.jboss.test.aop.test.ScopedWovenDependencyTestCase

      The error message is:
      javax.management.RuntimeErrorException
      at org.jboss.mx.interceptor.ReflectedDispatcher.handleInvocationExceptions(ReflectedDispatcher.java:182)
      at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:165)
      at org.jboss.mx.server.Invocation.dispatch(Invocation.java:96)
      at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
      at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
      at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:668)
      at org.jboss.jmx.connector.invoker.InvokerAdaptorService.invoke(InvokerAdaptorService.java:263)
      at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:157)
      at org.jboss.mx.server.Invocation.dispatch(Invocation.java:96)
      at org.jboss.mx.interceptor.AbstractInterceptor.invoke(AbstractInterceptor.java:138)
      at org.jboss.mx.server.Invocation.invoke(Invocation.java:90)
      at org.jboss.mx.interceptor.ModelMBeanOperationInterceptor.invoke(ModelMBeanOperationInterceptor.java:140)
      at org.jboss.jmx.connector.invoker.SerializableInterceptor.invoke(SerializableInterceptor.java:74)
      at org.jboss.mx.server.Invocation.invoke(Invocation.java:90)
      at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
      at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:668)
      at org.jboss.invocation.jrmp.server.JRMPProxyFactory.invoke(JRMPProxyFactory.java:180)
      at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:157)
      at org.jboss.mx.server.Invocation.dispatch(Invocation.java:96)
      at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
      at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
      at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:668)
      at org.jboss.invocation.jrmp.server.JRMPInvoker$MBeanServerAction.invoke(JRMPInvoker.java:855)
      at org.jboss.invocation.jrmp.server.JRMPInvoker.invoke(JRMPInvoker.java:422)
      at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:309)
      at sun.rmi.transport.Transport$1.run(Transport.java:168)
      at java.security.AccessController.doPrivileged(AccessController.java:279)
      at sun.rmi.transport.Transport.serviceCall(Transport.java:164)
      at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:506)
      at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.handleRequest(TCPTransport.java:838)
      at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:912)
      at java.lang.Thread.run(Thread.java:810)
      Caused by: java.lang.ExceptionInInitializerError
      at java.lang.J9VMInternals.initialize(J9VMInternals.java:216)
      at org.jboss.test.aop.jdk15annotated.ScopedAnnotatedTester.testBinding(ScopedAnnotatedTester.java:50)
      at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:157)
      Caused by: java.lang.NullPointerException
      at org.jboss.aop.Domain$1.run(Domain.java:124)
      at org.jboss.aop.Domain$1.run(Domain.java:121)
      at java.security.AccessController.doPrivileged(AccessController.java:197)
      at org.jboss.aop.Domain.getDomainName(Domain.java:119)
      at org.jboss.test.aop.jdk15annotated.POJO$POJOAdvisor.initialise(POJO$POJOAdvisor.java)
      at org.jboss.test.aop.jdk15annotated.POJO$POJOAdvisor.<init>(POJO$POJOAdvisor.java)
      at org.jboss.test.aop.jdk15annotated.POJO.<clinit>(POJO.java)
      at java.lang.J9VMInternals.initializeImpl(Native Method)
      at java.lang.J9VMInternals.initialize(J9VMInternals.java:194)

        Gliffy Diagrams

          Issue Links

            Activity

            mmalina Martin Malina added a comment -

            Attached the test result XML file.

            shelly.mcgowan Shelly McGowan added a comment -

            Upgrading my local workspace with 2.1.0.GA, still see errors in these tests:
            Caused by: java.lang.ExceptionInInitializerError
            at java.lang.J9VMInternals.initialize(J9VMInternals.java:218)
            at org.jboss.test.aop.jdk15annotated.ScopedAnnotatedTester.testCompostition(ScopedAnnotatedTester.java:144)
            at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:157)
            Caused by: java.lang.NullPointerException
            at org.jboss.aop.instrument.JoinPointGenerator.findAdvisedField(JoinPointGenerator.java:499)
            at org.jboss.aop.instrument.JoinPointGenerator.<init>(JoinPointGenerator.java:187)
            at org.jboss.aop.instrument.MethodJoinPointGenerator.<init>(MethodJoinPointGenerator.java:74)
            at org.jboss.aop.GeneratedClassAdvisor$ClassAdvisorStrategy.getJoinPointGenerator(GeneratedClassAdvisor.java:1311)
            at org.jboss.aop.GeneratedClassAdvisor.getJoinPointGenerator(GeneratedClassAdvisor.java:778)
            at org.jboss.aop.GeneratedClassAdvisor.fullWorkFinalizeMethodChain(GeneratedClassAdvisor.java:632)
            at org.jboss.aop.GeneratedClassAdvisor.finalizeMethodChain(GeneratedClassAdvisor.java:596)
            at org.jboss.aop.GeneratedClassAdvisor.finalizeChains(GeneratedClassAdvisor.java:577)
            at org.jboss.aop.ClassAdvisor.createInterceptorChains(ClassAdvisor.java:609)
            at org.jboss.aop.GeneratedClassAdvisor.access$201(GeneratedClassAdvisor.java:65)
            at org.jboss.aop.GeneratedClassAdvisor$ClassAdvisorStrategy.createInterceptorChains(GeneratedClassAdvisor.java:1303)
            at org.jboss.aop.GeneratedClassAdvisor.createInterceptorChains(GeneratedClassAdvisor.java:407)

            shelly.mcgowan Shelly McGowan added a comment -

            Correction to above comment: results after upgrading to JBoss AOP 2.1.2.GA in my local workspace.

            shelly.mcgowan Shelly McGowan added a comment -

            Resolved with JBoss AOP 2.1.3.GA and MC 2.0.8.GA.


              People

              • Assignee:
                shelly.mcgowan Shelly McGowan
                Reporter:
                mmalina Martin Malina
              • Votes:
                1 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Development