Uploaded image for project: 'Application Server 3  4  5 and 6'
  1. Application Server 3 4 5 and 6
  2. JBAS-6803

java.lang.InterruptedException thrown from getNonDurableSubscriptionsCount

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: 6.0.0.M1
    • Component/s: None
    • Labels:
      None

      Description

      This InterruptedException was discussed as part of JBAS-6546 which was closed as the hang was no longer seen. This InterruptedException is still unresolved and seen in the admin-console test: org.jboss.jopr.jsfunit.as5.JMSTest#testQueueStopOperation

      java.lang.InterruptedException
      at EDU.oswego.cs.dl.util.concurrent.WriterPreferenceReadWriteLock$ReaderLock.acquire(WriterPreferenceReadWriteLock.java:157)
      at org.jboss.messaging.core.impl.postoffice.MessagingPostOffice.getQueuesForCondition(MessagingPostOffice.java:524)
      at org.jboss.jms.server.destination.ManagedTopic.getSubscriptionsCount(ManagedTopic.java:308)
      at org.jboss.jms.server.destination.ManagedTopic.getNonDurableSubscriptionsCount(ManagedTopic.java:104)
      at org.jboss.jms.server.destination.TopicService.getNonDurableSubscriptionsCount(TopicService.java:305)

      Previously discussed here:
      https://jira.jboss.org/jira/browse/JBAS-6546?focusedCommentId=12455886#action_12455886

        Gliffy Diagrams

          Issue Links

            Activity

            ccrouch Charles Crouch added a comment -

            Could you attach TRACE level logs from org.jboss.on and org.rhq from when this condition occurs

            shelly.mcgowan Shelly McGowan added a comment -

            Attaching the output for one of the WAR tests which contains malformed web.xml and expect the deployment to fail.

            shelly.mcgowan Shelly McGowan added a comment -

            This issue is not being seen in JBoss AS rev 88276, EMBJOPR 386 but will leave it Open as testing continues.

            shelly.mcgowan Shelly McGowan added a comment -

            Spoke too soon. This is still being seen in a full test run. Debugging in progress.

            dmlloyd David Lloyd added a comment -

            Someone on the JBM team needs to reevaluate this code. IIRC it's falling out because it happens in a method which throws Exception so someone "forgot" to handle it. There needs to be some kind of reasonable semantics for when this code is interrupted.

            jason.greene Jason Greene added a comment -

            There will not be a 5.1.1, moving to 5.2 for now

            ips Ian Springer added a comment -

            We should either move this to JBMESSAGING so someone from the Messaging team can fix the handling of the InterrupedException, or we should just resolve it.

            There is the more critical issue of why the as5 plugin is interrupting the thread to begin with, but that's a separate issue (Shelly is trying to reproduce it outside of the test suite).

            jason.greene Jason Greene added a comment -

            Resolving as requested.


              People

              • Assignee:
                shelly.mcgowan Shelly McGowan
                Reporter:
                shelly.mcgowan Shelly McGowan
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Development