Uploaded image for project: 'Application Server 3  4  5 and 6'
  1. Application Server 3 4 5 and 6
  2. JBAS-6758

Entering Global JNDI name in embedded console for new ConnectionFactory results in FileNotFoundException

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: JBossAS-5.1.0.GA
    • Fix Version/s: 6.0.0.M1
    • Component/s: ProfileService
    • Labels:
      None

      Description

      When entering a Global JNDI name using

      eis/ejb_Deployment, an attempt to create the new resource results in the following Exception. Using ejb_Deployment only is successful.

      Failed to add Resource (see app server log for additional details): java.lang.RuntimeException:Failed to process template. -> java.lang.RuntimeException:java.io.FileNotFoundException: /TEST/Branch_5_x/build/output/jboss-5.1.0.CR1/server/all/deploy/eis/ejb_Deployment-ds.xml (No such file or directory) -> java.io.FileNotFoundException:/TEST/Branch_5_x/build/output/jboss-5.1.0.CR1/server/all/deploy/eis/ejb_Deployment-ds.xml (No such file or directory)

      Caused by: java.lang.RuntimeException: java.io.FileNotFoundException: /TEST/Branch_5_x/build/output/jboss-5.1.0.CR1/server/all/deploy/eis/ejb_Deployment_whitebox-tx.rar-ds.xml (No such file or directory)
      at org.jboss.profileservice.management.upload.remoting.StreamingDeploymentTarget.transferDeployment(StreamingDeploymentTarget.java:287)
      at org.jboss.profileservice.management.upload.remoting.StreamingDeploymentTarget.distribute(StreamingDeploymentTarget.java:107)
      at org.jboss.profileservice.management.upload.DeploymentProgressImpl.distribute(DeploymentProgressImpl.java:177)
      at org.jboss.profileservice.management.upload.DeploymentProgressImpl.run(DeploymentProgressImpl.java:82)
      at org.jboss.profileservice.management.AbstractTemplateCreator.distribute(AbstractTemplateCreator.java:158)
      at org.jboss.profileservice.management.AbstractTemplateCreator.applyTemplate(AbstractTemplateCreator.java:99)
      at org.jboss.profileservice.management.ManagementViewImpl.applyTemplate(ManagementViewImpl.java:1005)
      <snip>
      Caused by: java.io.FileNotFoundException: /TEST/Branch_5_x/build/output/jboss-5.1.0.CR1/server/all/deploy/eis/ejb_Deployment_whitebox-tx.rar-ds.xml (No such file or directory)
      at java.io.FileOutputStream.open(Native Method)
      at java.io.FileOutputStream.<init>(FileOutputStream.java:179)
      at java.io.FileOutputStream.<init>(FileOutputStream.java:131)
      at org.jboss.system.server.profileservice.repository.BasicDeploymentRepository.addDeploymentContent(BasicDeploymentRepository.java:147)

        Gliffy Diagrams

          Issue Links

            Activity

            ips Ian Springer added a comment -

            If on Windows (or perhaps always), we should also escape other characters which are illegal in Windows filenames:

            / \ : * ? " < > |

            Also, the space and the period are not allowed as the final character of a Windows filename.

            emuckenhuber Emanuel Muckenhuber added a comment -

            Hmm - so with all this replacing in place how is one supposed to create a deployment in a sub-folder?

            ccrouch Charles Crouch added a comment -

            I thought one of the points of the ProfileService was to abstract away the fact that deployment descriptors eventually get written to the file system when creating a new resource? If we want to add support for hierarchical/grouped deployments into the ProfileService as a top-level concept (if its not there already) then thats a different/bigger question.

            jason.greene Jason Greene added a comment -

            There will not be a 5.1.1, moving to 5.2 for now

            emuckenhuber Emanuel Muckenhuber added a comment -

            This should be fixed as well.


              People

              • Assignee:
                emuckenhuber Emanuel Muckenhuber
                Reporter:
                shelly.mcgowan Shelly McGowan
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Development