Uploaded image for project: 'Forge: Jansi'
  1. Forge: Jansi
  2. JANSI-12

FUSE Mediation Router Source build fails

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Labels:
      None
    • Environment:
      Windows XP, (3GB Ram), tried cygwin + windows cmd.exe (same result)

      Description

      Hi,

      I tried building the latest source from FUSE Mediation Router (fuse-mediation-router-1.6.2.1-src) and get the following error. On my first try I ran out of Heap Space so I changed that by setting MAVEN_OPTS="-Xmx512m -XX:MaxPermSize=384m". Now I get the following error, see below:

      mvn -e clean install -Dmaven.test.skip=true

      ...
      [INFO] ------------------------------------------------------------------------
      [INFO] Building Camel :: MSMQ
      [INFO]    task-segment: [clean, install]
      [INFO] ------------------------------------------------------------------------
      [INFO] [clean:clean {execution: default-clean}]
      [INFO] Deleting file-set: C:\Entwicklungsumgebung\esb\fuse-mediation-router-1.6.2.1-src\apache-camel-1.6.2.1-fuse\components\camel-msmq/tmplib (included: [], excluded: [])
      [INFO] [exec:exec {execution: clean}]
      [INFO] Der Befehl "nmake" ist entweder falsch geschrieben oder
      [INFO] konnte nicht gefunden werden.
      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] Result of cmd.exe /X /C "nmake clean" execution is: '1'.
      [INFO] ------------------------------------------------------------------------
      [INFO] Trace
      org.apache.maven.lifecycle.LifecycleExecutionException: Result of cmd.exe /X /C "nmake clean" execution is: '1'.
              at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:719)
              at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLifecycle(DefaultLifecycleExecutor.java:556)
              at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:535)
              at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:387)
              at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:348)
              at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:180)
              at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328)
              at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
              at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
              at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60)
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
              at java.lang.reflect.Method.invoke(Method.java:597)
              at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
              at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
              at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
              at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
      Caused by: org.apache.maven.plugin.MojoExecutionException: Result of cmd.exe /X /C "nmake clean" execution is: '1'.
              at org.codehaus.mojo.exec.ExecMojo.execute(ExecMojo.java:283)
              at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:490)
              at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:694)
              ... 17 more
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 1 minute 54 seconds
      [INFO] Finished at: Mon Feb 15 10:10:59 CET 2010
      [INFO] Final Memory: 193M/345M
      [INFO] ------------------------------------------------------------------------

      For now I will remove MSMQ from the build.

      Additional Info:

      Building FUSE ESB v.4 worked without any problems.

        Gliffy Diagrams

          Activity

          chirino Hiram Chirino added a comment -

          Reported issue is a Camel issue not a JANSI issue.. you should re-open you issue in the camel issue tracker:
          http://issues.apache.org/activemq/browse/CAMEL


            People

            • Assignee:
              chirino Hiram Chirino
              Reporter:
              mbirkner Marcel Birkner
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development