Following JCache, who does not recommend naming caches starting with java. or javax., we should start our internal cache names with org.infinispan.
However, as Radim said:
From systematic POV, +1. For marshalling it would bring another 11 bytes, which is not ideal, so we might consider encoding that differently. Not sure how error-prone would some naming that has non-trivial transformation be.