Immutant
  1. Immutant
  2. IMMUTANT-243

Unscheduling a job immediately after scheduling it fails

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved (View Workflow)
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: 0.9.0
    • Fix Version/s: 0.10.0
    • Labels:
      None
    • Similar Issues:
      Show 10 results 

      Description

      Loading this file results in the every-5s-forever job continuing to run: https://github.com/jcrossley3/random-apps-of-kindness/blob/master/demo/src/demo/jobs.clj

        Activity

        Jim Crossley
        added a comment -

        Further, once the unschedule fails, subsequent unschedule's also fail, leaving me no way to cancel the job short of undeploying.

        Show
        Jim Crossley
        added a comment - Further, once the unschedule fails, subsequent unschedule's also fail, leaving me no way to cancel the job short of undeploying.
        Toby Crawley
        added a comment -

        This issue was caused by the job being created asynchronously, and
        stop checking to see if the job was started before trying to stop. It
        will now check to see if the job is pending (thanks to
        https://github.com/projectodd/jboss-polyglot/commit/526dd8517d9c856e702cb5c454278d6120abed31),
        and wait for the job to reach the started state before actually
        stopping it. Depending on the schedule for the job, it may actually
        fire before being stopped.

        Show
        Toby Crawley
        added a comment - This issue was caused by the job being created asynchronously, and stop checking to see if the job was started before trying to stop. It will now check to see if the job is pending (thanks to https://github.com/projectodd/jboss-polyglot/commit/526dd8517d9c856e702cb5c454278d6120abed31 ), and wait for the job to reach the started state before actually stopping it. Depending on the schedule for the job, it may actually fire before being stopped.

          People

          • Assignee:
            Toby Crawley
            Reporter:
            Jim Crossley
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: